Forums > MaxMSP

Need a bit of troubleshooting help

March 19, 2010 | 1:20 am

I have a large patcher, that until today, ran just fine in WindowsXP with the MOTU ASIO driver and a MOTU 896 interface. Now, when I try to set the DSP window to the MOTU ASIO driver, I get the following message in the Max window:

MSP/ASIO: error loading ASIO driver for L7
MSP ASIO: Error -1 loading driver MOTU Audio ASIO.

The odd part is that I can load this driver in other patchers and in the standalone that was created from this patcher. It just won’t let me load it in this patcher. I can also load the mme driver with no problems.

I tried deleting and replacing the [dac~] and [adc~] objects. I’ve also deleted the Max Preference files and removed and reinstalled both Max and the MOTU audio drivers. The same patch works fine on my Mac.

Any suggestions to look at are greatly appreciated. Thanks!


March 19, 2010 | 3:31 am

The deleting and replacing thing is a good way to head out.Cut, save as, paste, might be another. At some point you will have cut enough out of the patch that you will be able to load it without getting this error.

-A


March 19, 2010 | 6:01 am

Yeah, that’s where I’m heading. I was hoping someone might be able to point me toward a specific area that has caused this sort of behavior for them. Oh well, I’ll keep digging and see what happens. Thanks.


March 20, 2010 | 1:16 am

Okay, I think I’ve narrowed it down to some sort of conflict with the MOTU ASIO driver and the Max preference files.

WindowsXP (32 bit), Max 5.1.3, MOTU 896HD (MOTU FW Audio Driver 3.7.39083)

If I first delete the "Max 5 Preferences Files" directory, then I can get my patch to open and can load the MOTU ASIO audio driver and everything works fine. However, if I then quit Max and attempt to relaunch the patcher, I get an error message that says:

MaxMSP has encountered a problem and needs to close. We are sorry for the inconvenience." (Hey, at least they’re polite about it.) This happens even if I hold Control-Shift to defeat any loadbang objects.

Then, if I do one of the two following, I can get my patcher to open:
1. Delete the Preferences directory again, or
2. Launch MaxMSP, go to DSP options and change the audio driver to mme.

Then I can launch my patcher just fine and switch it to MOTU ASIO and it works just fine. If I set the audio driver back to mme before closing my patcher, I can even reopen without going through the drill above.

I tried this with two different ASIO drivers/interfaces. One was an M-Audio FireWire 410 that works just fine. The problem seems to be only with the MOTU ASIO driver for the MOTU 896HD. (and yes, I’ve downloaded the newest version of the driver from MOTU.)

The irony, is that the driver itself works fine, in both Max and in other applications. It’s just after I have used it and quit Max that something happens in the preferences that messes things up.


March 20, 2010 | 3:16 am

ok , sorry for the PITA this is.

make a message box with

; dsp driver print

in it, click on it with your MOTU box as the current ASIO driver

Let’s have a look at what ends up in the Max window – we’ll probably move this into support.

Let’s also have a look at the contents of the audio preference file which gets saved when you quit Max.

Cheers

-A


March 20, 2010 | 4:21 am

Thanks, Andrew! Here’s the dsp driver print report:

ASIO Driver Info:
name: MOTU Audio ASIO
ad_asio version: Feb 15 2010 15:34:21
inputs: 12
outputs: 14
iovs: 512
input latency 556 samples
output latency 1030 samples
asio_bufferswitchtimeinfo() has been called
minbs: 512
maxbs: 512
prefbs: 512
gran: 0
numrates: 6
rate 0: 44100
rate 1: 48000
rate 2: 88200
rate 3: 96000
rate 4: 176400
rate 5: 192000
input channel 0 format: 18
input channel 1 format: 18
input channel 2 format: 18
input channel 3 format: 18
input channel 4 format: 18
input channel 5 format: 18
input channel 6 format: 18
input channel 7 format: 18
input channel 8 format: 18
input channel 9 format: 18
input channel 10 format: 18
input channel 11 format: 18
output channel 0 format: 18
output channel 1 format: 18
output channel 2 format: 18
output channel 3 format: 18
output channel 4 format: 18
output channel 5 format: 18
output channel 6 format: 18
output channel 7 format: 18
output channel 8 format: 18
output channel 9 format: 18
output channel 10 format: 18
output channel 11 format: 18
output channel 12 format: 18
output channel 13 format: 18

audioprefs.txt (is that the right file?):

max v2;
dsp prefdrivername ad_asio;
dsp prefsubname "MOTU Audio ASIO";


Viewing 6 posts - 1 through 6 (of 6 total)