Forums > MaxMSP

Need Help with Yamaha FS1R Sysex

March 25, 2012 | 3:30 pm

Hi!
So i make a maxforlive device for my FS1R. No problem with CC and NRPN stuff (have to read a lot but it works).
I think i have read all Sysex post i found in the Forum .
My problem is, if i put a sysex string [Filter Cutoff Freq]( F0 43 11 5E 33 00 18 00 7f F7)in the Programm Midi OX my FS1R response and shows an E (for edit Sound) on the front panel. So I put an (0xF0 0×43 0×11 0x5E 0×33 0×00 0×18 0×00 0x7f 0xF7) in Sxformat and get an (Sxformat 240 67 17 94 51 0 24 0 127 247).
I put it in Midiout and Bang the Message. No response. The same with an live dial. I try an (sxformat 240 67 17 94 51 0 24 / is $2 / is $1 / 247) and many different variants no-response.
In the Manual on Page 39 Performance Part Parameter says: F0 43 1n 5E 3p 00 ll vv vv F7 p=0..3 (Part1..3)
[Filter Cutoff Freq] ll=18 vv=00 vv=7F

http://www2.yamaha.co.jp/manual/pdf/emi/english/synth/FS1RE2.PDF

So why i get an response on Midi OX but not in max ?
What i am doing wrong ?
in the manual on Page 37 is this info:

Parameter Change
11110000 F0 Exclusive Status
01000011 43 YAMAHA ID
0001nnnn 1n Device Number
01011110 5E Model ID
0gggpppp gggpppp *Parameter Address High (H)
0mmmmmmm mmmmmmm *Parameter Address Middle (M)
0lllllll lllllll *Parameter Address Low (L)
0vvvvvvv vvvvvvv Data Value MS 7bit
0vvvvvvv vvvvvvv Data Value LS 7bit
11110111 F7 End of Exclusive

I was truly grateful I hope there is another FS1R User or "SYSEX GURU" who can help me.
Thank you in advance !!
Sven
Barmstedt/Germany

– Pasted Max Patch, click to expand. –

March 25, 2012 | 3:38 pm

$i1
Make sure to put the "i" to indicate integer.
Also right/command click midiout and make sure it’s routed to output to your synth.
Hope this helps!


March 25, 2012 | 3:57 pm

THX for your quick answer Lume !
To be honest i don´t understand what you mean…
Can you please edit it on my Max patch so that i can see what you mean ?
This would be great if you can do it !
THX!!


March 25, 2012 | 4:27 pm

Okay, please try this. You may have to connect something a different way.
EDIT: Fixed it up a bit.

– Pasted Max Patch, click to expand. –

March 25, 2012 | 5:42 pm

It dont work for me, but now with the textedit i can see what i am sending.
this is great thank you ! what i see is when i put the Sxformat 240 67 17 94 51 0 24 0 127 247 and bang it, its the same as on MIDI OX and it still works there.
You write:"Also right/command click midiout and make sure it’s routed to output to your synth."
Every ctlout CC Number i send works. Also the NRPN Stuff.So under Live, using max4live(Win7 64) take the right Midioutput what else can i do?


March 25, 2012 | 5:54 pm

Hey mate, I looked at it very closely and I think this will work!
You only wanted to change 1 variable in the [sxformat].

– Pasted Max Patch, click to expand. –

March 25, 2012 | 6:28 pm

This is what i wanted, yes but it still not work.. :-(
and i don´t know why… BUT I HAVE TO SAY THANK YOU 1000 times that you still try to help me !! When i look again on the Parameter Change

11110000 F0 Exclusive Status
01000011 43 YAMAHA ID
0001nnnn 1n Device Number
01011110 5E Model ID
0gggpppp gggpppp *Parameter Address High (H)
0mmmmmmm mmmmmmm *Parameter Address Middle (M)
0lllllll lllllll *Parameter Address Low (L)
0vvvvvvv vvvvvvv Data Value MS 7bit
0vvvvvvv vvvvvvv Data Value LS 7bit
11110111 F7 End of Exclusive

i am cofused and think i am not on the right way, but why is this string working in MIDI OX ???


March 26, 2012 | 5:15 am

I have no idea. My help is limited because i don’t run M4L.

Pardon me if this is obvious, but did you try hooking it up to the midiout like this?:

– Pasted Max Patch, click to expand. –

March 26, 2012 | 2:26 pm

Yes, I done it that way. So i have a new idea. But it will take some time. If the experiment finished i will post the result. Again i have to thank you, and i am very happy that you toke the time to find out the cause.
THX!


March 26, 2012 | 2:37 pm

sysex out is turned on in live, yes?


March 26, 2012 | 5:15 pm

@Roman Sorry,what do you mean with "sysex out is turned on in live, yes? " is it by default off ? cant find anything in live manual..


April 1, 2012 | 4:27 pm

You cannot use SysEx in Ableton Live. Look at "four": http://createdigitalmusic.com/2009/11/max-for-live-guide-10-things-you-should-know-release-details-pricing-videos/


April 1, 2012 | 7:04 pm

can you use Leigh Hunts midiout replacement objects to go straight out to any MIDIport you want bypassing Live’s restrictions with SYSEX – I think that’s right – osx only – http://web.mac.com/leighhunt/iWeb/Site/downloads.html


Viewing 13 posts - 1 through 13 (of 13 total)