need vst~ help

Nov 28, 2011 at 7:57am

need vst~ help

I’m trying to use the Cheeze Machine string-synth VST plugin (freeware) with the [vst~] object in Max 5.

I’m able to get the plugin to load (sending an “open” message to the top left inlet of [vst~] lets me see the plugin), and I’m able to change the plugin’s parameters through the [vst~] object, but I’m not getting any sound.

When I send the “get -1″ message to get the number of inputs for the plugin, I get a “0″ out of the Parameter Index outlet.

Is this an issue with the plugin or with how I’m using the [vst~] object? I haven’t used any VST plugins before, let alone using them in Max, so I would appreciate any help on this.

#60301
Nov 28, 2011 at 11:27am

Notice that [vst~] requires midi input in a special format, ie. raw midi bytes with prefix ‘midievent’.
For example, note on channel 1, pitch 60, velocity 80 would be .

#217055
Nov 28, 2011 at 3:04pm

Also notice vst~ is a MSP object and it needs the audio to be turned on, even if you’re dealing with midi.

#217056
Nov 28, 2011 at 3:10pm

Thanks!

Now I just need to find a way to make a glissando. I’m trying to change frequency to MIDI values in a continuous microtonal glissando driven by a [line] object. Is there a MIDI message to send to the [vst~] that will allow for this? Or is glissando not allowed with this particular plugin?

I am using the [ftom] object, but I’m only getting half steps to sound. I know the MIDI range is probably the issue… is there a way to scale it so that I hear a continuous glissando?

Here is my patch so far:

– Pasted Max Patch, click to expand. –
Attachments:
  1. vstworking.maxpat
#217057
Dec 1, 2011 at 10:52pm

The MIDI protocol is limited to 128 notes, so if you want microtonal or glissandi, your best bet to ‘fill the gaps’ is pitchbend, which may or may not be supported by your VST

#217058

You must be logged in to reply to this topic.