Forums > Misc

new forum front-end and mobile browser


Jan
May 13, 2014 | 2:54 am

While the the new forum front-end looks and works great on a regular browser, it’s unfortunately very difficult to read on my mobile browser. (see screenshot). Is that due to my ancient phone or are others seeing the same?

  • This topic was modified 3 months by  Ginger.
Attachments:
  1. SC20140513-114631

May 13, 2014 | 9:13 am

Hi Jan,

You might have caught us in the middle of the update for this. But to be sure, can you let me know what device you’re using and browser?

If you prefer, you can also send me an email at ginger@mainsocial.com.


May 13, 2014 | 2:02 pm

@ Ginger: does this update affect search functionality? Since yesterday I get only the header with "Search results", nothing else, no results.


May 13, 2014 | 2:41 pm

Hi Thinksamuel, yes, the search page was down for a little bit, but it should be up and running now!



Jan
May 14, 2014 | 4:04 am

Dear Ginger,

I cleared all caches and reloaded scripts to be sure to have the latest css files loaded. The site still looks the same.
My mobile phone is a Samsung Galaxy ACE GT-S5830 (first version of the Galaxy ACE). It’s running Android 2.3 (yeah i know it’s very old ;) ). I am using the Android browser (not chrome) as well as Opera Mini. That pages sometimes don’t render correctly on Opera happens also with other sites – that’s due to the data-compression/server-side rendering Opera uses. But in this case the screens look the same on both browsers.

Best Jan



Jan
May 14, 2014 | 4:18 am

Hi Ginger,

this is just for informational purpose: The forum site now throws a JavaScript error when being logged in and viewing a thread:

 Uncaught ReferenceError: _kmq is not defined (index):77
(anonymous function)

the error refers to this inline-script:

<script>
    _kmq.push(['identify', 'jan@janmech.de']);
    _gaq.push(['_setCustomVar',
          1,             // This custom var is set to slot #1.  Required parameter.
          'Login Status',   // The name of the custom variable.  Required parameter.
          'Logged In',      // Sets the value of "User Type" to "Member" or "Visitor" depending on status.  Required parameter.
          'jan@janmech.de',
           2             // Sets the scope to session-level.  Optional parameter.
       ]);
    _gaq.push(['_trackEvent', 'Login Status', 'Logged In', 'jan@janmech.de']);
  </script>

it’s this line that breaks the code :

_kmq.push(['identify', 'jan@janmech.de']);

I haven’t noticed any direct breaking of functionality so far on chrome, but my guess is that older Internet Explorers might be affected by that as they usually stop executing scrips on errors….

Cheer,

Jan



Lee
May 14, 2014 | 4:39 am

I’ve noticed some display issues with the top menu bar on Chrome on Windows. Explorer is fine…


May 14, 2014 | 1:25 pm

Thanks for the heads-up, Jan. I’ve cleaned up that code.

Lee, can you specify what you actually see when you say "display issues"? A screenshot would be great as well, so I can look into it further.


May 15, 2014 | 11:05 am

wow, as of today the support for safari 4 is gone totally?

the ajax menu (which does not display since 3 weeks) now fills the whole site and you can no longer scroll down to the forum entries. :)

the scrollbar scrolls the page only as far as seen in the picture – when it reached that position, it starts to scroll only the content of the subframe (where you can see a bit of a forum post)

Attachments:
  1. safari413ppc2014-05-15

May 15, 2014 | 11:08 am

Hi dudes, just letting you know that I’m working on this right now. Thanks for all the feedback and help!



Jan
May 17, 2014 | 1:56 am

Hi Ginger,

sorry for making another remark … I know you are still working on the updates. I noticed that when I view the threads I am inscribed to (in the profile section) they seem to be ordered (my?) last reply-date ascending. So the newest ones are at the bottom. The list under the authored-tab places the newest ones at the top (which I think is the better way ;) ).

cheers,

jan


May 22, 2014 | 9:35 am

Hey @Jan. No worries. We all use the site, so any suggestions and feedback are welcome. You’re right about the topics/replies being in reverse order on the profiles section. I’ve updated this to start at the most recent ones now.


Viewing 12 posts - 1 through 12 (of 12 total)