Forums > MaxMSP

new from clipboard trouble

October 2, 2006 | 11:10 pm

When pasting text format into a new patcher, Command-Shift-N doesn’t
work unless at least one patcher has already been open and remains open.

Steps to reproduce:

1 copy text format patch from an email,
2 launch Max/MSP
3 attempt to paste to new patcher with Command-Shift-N or choose new
from clipboard from the file menu
4 nothing happens, except the File menu blinks with each attempt
5 open new patcher using Command-N or choosing New -> Patcher from
File menu
6 now Command-Shift-N will create a second new patcher with the
pasted code in it

MacBook Pro 2.16GHz, 2GB, 10.4.8
Max/MSP 4.6.2, Jitter 1.6.2

also shows up on

PowerBook 1.33GHz, 1GB, 10.4.7
Max/MSP 4.5.7, Jitter 1.5.2

Anyone else?

Vlad Spears
Urbi et orbi

http://www.2secondfuse.com


October 3, 2006 | 8:29 am

Unless it’s been added in 4.6.2, the Command-Shift-N
key combo is not built in to Max – if you ever had
that functionality, then it’s probably because you
used the AddShortcuts2Max script that comes with the
Ejies; I know this because I spent ages trying to
remember where it came from, after I updated to 4.6.
cheers
Roger
— Vlad Spears wrote:

> When pasting text format into a new patcher,
> Command-Shift-N doesn’t
> work unless at least one patcher has already been
> open and remains open.
>
> Steps to reproduce:
>
> 1 copy text format patch from an email,
> 2 launch Max/MSP
> 3 attempt to paste to new patcher with
> Command-Shift-N or choose new
> from clipboard from the file menu
> 4 nothing happens, except the File menu blinks with
> each attempt
> 5 open new patcher using Command-N or choosing New
> -> Patcher from
> File menu
> 6 now Command-Shift-N will create a second new
> patcher with the
> pasted code in it
>
> MacBook Pro 2.16GHz, 2GB, 10.4.8
> Max/MSP 4.6.2, Jitter 1.6.2
>
> also shows up on
>
> PowerBook 1.33GHz, 1GB, 10.4.7
> Max/MSP 4.5.7, Jitter 1.5.2
>
> Anyone else?
>
>
> Vlad Spears
> Urbi et orbi
> http://www.2secondfuse.com
>
>
>


October 3, 2006 | 8:58 am

On 3 oct. 06, at 10:29, ROGER CARRUTHERS wrote:

> you used the AddShortcuts2Max script that comes with the
> Ejies; I know this because I spent ages trying to
> remember where it came from, after I updated to 4.6.

Right. But Vlad problem seems different, because if he uses the
commands from the menu it won’t work either. I can’t reproduce that
behavior anyway (event with a clean max-startup folder).

Best,
ej



jln
October 3, 2006 | 9:39 am

It doesn’t work either here if NO window is opened (shortcut nor menu). I assume the Max window is closed in Vlad’s situation and that it is not in Ej’s.

I noticed this as well. However, I can’t remember if I posted something about this or if I only thought about doing it…

Anyway, the quick fix is probably to select "Max window at startup" in the option menu.

hth,

Best,

Julien.


October 3, 2006 | 10:06 am

On 3 oct. 06, at 11:39, jln wrote:

> It doesn’t work either here if NO window is opened (shortcut nor
> menu). I assume the Max window is closed in Vlad’s situation and
> that it is not in Ej’s.

Confirmed here. Displaying Max window at startup does the trick. Good
to know…

Thanks,
ej


October 3, 2006 | 5:42 pm

Yes, it seems to be the case that as long as any patcher or the Max
window is open, then New From Clipboard works, both choosing from the
menu and using the installed Ejies command shortcut. The Ejies
shortcuts have become such a useful part of my workflow that I keep
forgetting they’re not part of the standard app.

Setting Max window to open on launch is the easy fix. Thanks Roger,
Emmanuel, Julien.

Vlad

On Oct 3, 2006, at 3:06 AM, Emmanuel Jourdan wrote:

> On 3 oct. 06, at 11:39, jln wrote:
>
>> It doesn’t work either here if NO window is opened (shortcut nor
>> menu). I assume the Max window is closed in Vlad’s situation and
>> that it is not in Ej’s.
>
> Confirmed here. Displaying Max window at startup does the trick.
> Good to know…
>
> Thanks,
> ej
>
>


Viewing 6 posts - 1 through 6 (of 6 total)