No Audio output from Max collective/App

May 3, 2009 at 5:35am

No Audio output from Max collective/App

I built a standalone application from a patch, and the audio files/DSP status and output are all working fine when i launch it on the machine it was created on (OSX 10.4), but there is no audio output when the application is launched on my other machine (OSX 10.5.6 – which doesnt have MAX installed). I’ve read a lot of posts, and have tried including the “ad folder” inside “Cycling-74″ with my standalone app. and/or collective but to no avail. What specifically am I utilizing in the ad folder that gets the drivers up and working with the application? Im missing something simple I know but I just cant get it. Thanks.

#43640
May 3, 2009 at 10:52am

Is there any error printed in the max window (cmd+m) ?

#156591
May 3, 2009 at 5:23pm

Im using sfplay ultimately out through an ezdac, but Ive included an adc object in a couple tests to see if I can get the dsp menu to come up – when I click on it to bring up the dsp settings, the max window spits out about 30 error messages. I attached a text file with the messsage list. Most of them are…

newobj: adstatus: No such object

Im not concerend with getting the DSP window interface, unless thats the only way to get the audio going

Ive simplified things until all I have is a basic “open” and “play” function in my standalone app. but still no luck.

Thanks

#156592
May 3, 2009 at 5:45pm

#1 add a standalone object in your patch, and make sure that Audio Support option is checked in its inspector

#2 add an abstraction called “DSP Status” in your patch (this will insure that all the necessary externals are included in the standalone to open the DSP Status window.

This should fix your issue.

#156593
May 3, 2009 at 6:41pm

Thanks so much Emmanuel. I wasn’t able to create an abstraction from “DSP Status” for some strange reason- But there’s a patch built into max called “IO” that has DSP as a sub…. so that worked.

thanks again

#156594
May 3, 2009 at 7:06pm

Make sure you write “DSP Status” with the quotes.

#156595
May 3, 2009 at 8:42pm

It still wont come up as valid object/abstraction…

#156596
May 3, 2009 at 9:19pm

Really? Which version of Max do you use? Do you see an error message in the Max window?

#156597
May 3, 2009 at 9:30pm

V. 5.0.4 …yeah, its pretty strange, Ive tried taking the DSP Status.maxpat and putting a copy of it inside the path folder and also tried renaming a copy of it and bringing it into an abstraction that way. The Max window just says no such object- Making a bpatcher and setting the patcher file to DSP Status.maxpat works though….

-P

#156598
May 4, 2009 at 7:29pm

First off, you definitely want to update to 5.0.7:

http://cycling74.com/downloads/max5

-Ben

#156599

You must be logged in to reply to this topic.