no audio output in exported patchers…

Oct 5, 2009 at 11:40am

no audio output in exported patchers…

Hey guys..
ill try to keep this as short as possible..

everytime i start max, i have to go over the dsp settings to set up my audio ouput correctly… on default its always set to “none”
not a big problem
but

when i export my final patch as an .exe and start it up… it will use max runtime to run it…
problem now, i dont get any sound out of it…
my guess is, that max runtime is using the “none” audio output too on default…
but i cant change the settings in the max runtime window…

i thought maybe i could use a unmenu for ezdac in my patch.. not possible..

so how can i solve this?

thanks in advance

#45733
Oct 5, 2009 at 1:23pm

Maybe you need to trash the prefs. I think max and runtime use the same prefs. It would be a useful feature to be able to set the driver from within your standalone. Making an object saying “DSP Status” will include the DSP status window to your patch.

#164911
Oct 5, 2009 at 11:11pm

Try editing the DSP Status window in the full version of Max. All the settings can be included in your patch with the [adstatus] objects. Easier is to include the whole patch, but you might not need all the options (or want to make them available, like signal or I/O vector sizes, which you might want to restrict).

#164912
Oct 7, 2009 at 10:58pm

Hey!

I was making patches for my ensemble today and had this problem. The best solution is to use an ‘adstatus’ object in your patch and attach a ubutton (not sure if that’s what its called) to it like in the help file for adstatus. adstatus takes an argument so use something like ‘adstatus driver’ and that should let you change the driver being used on any machine you run this patch on when using max5 runtime.

-Christopher

#164913
Oct 7, 2009 at 11:18pm

add this to include the dsp status patcher in your standalone

– Pasted Max Patch, click to expand. –
#164914

You must be logged in to reply to this topic.