NOT PERFECTLY SMOOTH, why ?

Mar 21, 2011 at 6:05pm

NOT PERFECTLY SMOOTH, why ?

Hi All,

I have problems of lags in a big patch,
I have approximatively 100 objects jit.gl.text2d witch are all moved independently by line objects.
Problem: In a sequence i have some freeze moments (during about 100 or 200 ms i think).
I tried to optimize scheduler settings. It’s better now but the the problem subsists.
Here is one element of my patch.
Even with this very simple patch, IT’S NOT PERFECTLY SMOOTH !!! Why?

Thanks for your help

– Pasted Max Patch, click to expand. –
#55721
Mar 21, 2011 at 7:13pm

I can’t guarantee that this will fix your problem but…
I’d advise looking into using bline (triggered by bangs from the same qmetro that’s driving your display) instead of line.

#200351
Mar 21, 2011 at 7:15pm

i would try bline, triggered by the same metro controlling rendering, instead of line.

#200352
Mar 21, 2011 at 7:32pm

I’m not sure multiple line objects are going to be the best solution, I’ve found it doesn’t take many line objects in my patch (especially one that’s already processor intensive) to make it drag.

Though I’ve found your patch works fairly well with the time grain to line reduced to 10 and running at 60 fps.

I’d suggest optimizing your patch to work with one line object at it’s lowest possible time grain, moving between start and end points with jit.xfade, and adjusting the position of each object before banging (aka. automatic 0).

I’ve got this one running at 40+ fps with 400 objects…

– Pasted Max Patch, click to expand. –

Hope this helps.

#200353
Mar 22, 2011 at 3:13pm

wooow..
just for curiosity i try this last patch in my machine and the framerate drops down and down when i go with more than 30 objetcs! with 40 objects i get 5 FPS!!

im in win7 64bit with the last Max version on a
Intel® Core™ i7-940XM Processor Extreme Edition
(8M Cache, 2.13 GHz)
and a gpu ATI Mobility 5870 1GB GDDR5

not a slower machine, but…

any idea?

thanks!

#200354
Mar 22, 2011 at 3:59pm

Hi carsol, If you mean 40 objects by adjusting the dim to 40, then you are actually running 40×40 = so actually 1600 (!). 400 is 20.

#200355
Mar 22, 2011 at 6:35pm

oh yeah man! i didnt take a good look to the patch…
anyway setting at 400 objects im getting 20FPS… half of you..
im curious which machine do you use?

btw, i always get better performance using gl.text3d instead of gl.text2d… with 400 objects and gl.text3d goes to 40FPS..

best!

#200356
Mar 22, 2011 at 10:46pm

Funny I found the opposite, I tried text3d and my patch ground to a halt.

Ah, the wonderfully zany world of computers…

Macbook Pro 13″ 2.53GHz 4GB

#200357

You must be logged in to reply to this topic.