notein bug again

Jan 11, 2007 at 10:09am

notein bug again

I’m having this strange notein bug again, and this time, i *really need
this to be taken care of, please*.

I left all the chain in the example patch below, in order to reproduce
the bug. This is the smallest i could go to nail the bug.

Problem is explained in the patch, but in the big lines :

- When DSP is turned on, the [sel] object doesn’t output anything out of
its right outlet when using the midi keyboard.
- When DSP is off, it does output something.

This is a crazy bug.

#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 235 281 26 9109513 print;
#P window linecount 2;
#P comment 333 296 259 9109513 6 – Now , use your midi keyboard. IT’S
NOT WORKING ANYMORE !!!!;
#P window linecount 1;
#P comment 333 279 259 9109513 5 – Hit the kslider , message will
change to ’1.’ , then to ‘bang’;
#P comment 333 262 108 9109513 4 – Now , turns audio on;
#P comment 333 243 259 9109513 3 – Use your midi keyboard. It’s working
the same.;
#P comment 333 226 259 9109513 2 – Hit the kslider , message will
change to ’1.’ , then to ‘bang’;
#P newex 208 125 80 9109513 makenote 0 1000;
#P user kslider 208 64 54 0 36 48 31 12 0 128 128 128 128 128 128 255
255 255 0 0 0 0 0 0;
#P user ezdac~ 152 349 196 382 0;
#P newex 153 201 32 9109513 / 127.;
#P newex 153 168 106 9109513 if $i1>0 then 127 else 0;
#P newex 138 122 40 9109513 notein;
#P message 153 306 50 9109513 bang;
#P newex 153 284 14 9109513 _;
#P window setfont “Sans Serif” 10.;
#P newex 153 235 67 9109514 sel 0;
#P window setfont “Sans Serif” 9.;
#P comment 333 209 100 9109513 1 – Leave audio off;
#P connect 1 1 2 0;
#P connect 1 1 15 0;
#P connect 6 0 1 0;
#P connect 4 1 5 0;
#P fasten 9 1 5 0 283 156 158 156;
#P connect 8 0 9 0;
#P fasten 8 1 9 1 540 121 248 121;
#P connect 5 0 6 0;
#P connect 2 0 3 0;
#P connect 1 0 2 0;
#P window clipboard copycount 16;

help !

If you don’t have this behavior, then please try to figure how it could
happens to me.

I’m on Windows XP SP2, using max 457. My keyboard is a Korg Kontrol 49
and it’s wired through USB2.

f.e

f.e chanfrault | aka | personal computer music
> >>>>>> http://www.personal-computer-music.com
> >>>>>> |sublime music for a desperate people|

#29610
Jan 11, 2007 at 10:14am

note : i’ve found a workaround, but it’s not fixing or explaining the
problem. If you chenge the [sel 0] to [sel 0.] (float), it works again.
It means that when the DSP is turn on, [sel] becomes is typechecking
with my keyboard, but NOT with the kslider…

I’ll kill someone.

f.e

f.e chanfrault | aka | personal computer music
> >>>>>> http://www.personal-computer-music.com
> >>>>>> |sublime music for a desperate people|

f.e wrote:
> I’m having this strange notein bug again, and this time, i *really
> need this to be taken care of, please*.
>
> I left all the chain in the example patch below, in order to reproduce
> the bug. This is the smallest i could go to nail the bug.
>
> Problem is explained in the patch, but in the big lines :
>
> – When DSP is turned on, the [sel] object doesn’t output anything out
> of its right outlet when using the midi keyboard.
> – When DSP is off, it does output something.
>
> This is a crazy bug.
>
> #P window setfont “Sans Serif” 9.;
> #P window linecount 1;
> #P newex 235 281 26 9109513 print;
> #P window linecount 2;
> #P comment 333 296 259 9109513 6 – Now , use your midi keyboard. IT’S
> NOT WORKING ANYMORE !!!!;
> #P window linecount 1;
> #P comment 333 279 259 9109513 5 – Hit the kslider , message will
> change to ’1.’ , then to ‘bang’;
> #P comment 333 262 108 9109513 4 – Now , turns audio on;
> #P comment 333 243 259 9109513 3 – Use your midi keyboard. It’s
> working the same.;
> #P comment 333 226 259 9109513 2 – Hit the kslider , message will
> change to ’1.’ , then to ‘bang’;
> #P newex 208 125 80 9109513 makenote 0 1000;
> #P user kslider 208 64 54 0 36 48 31 12 0 128 128 128 128 128 128 255
> 255 255 0 0 0 0 0 0;
> #P user ezdac~ 152 349 196 382 0;
> #P newex 153 201 32 9109513 / 127.;
> #P newex 153 168 106 9109513 if $i1>0 then 127 else 0;
> #P newex 138 122 40 9109513 notein;
> #P message 153 306 50 9109513 bang;
> #P newex 153 284 14 9109513 _;
> #P window setfont “Sans Serif” 10.;
> #P newex 153 235 67 9109514 sel 0;
> #P window setfont “Sans Serif” 9.;
> #P comment 333 209 100 9109513 1 – Leave audio off;
> #P connect 1 1 2 0;
> #P connect 1 1 15 0;
> #P connect 6 0 1 0;
> #P connect 4 1 5 0;
> #P fasten 9 1 5 0 283 156 158 156;
> #P connect 8 0 9 0;
> #P fasten 8 1 9 1 540 121 248 121;
> #P connect 5 0 6 0;
> #P connect 2 0 3 0;
> #P connect 1 0 2 0;
> #P window clipboard copycount 16;
>
> help !
>
> If you don’t have this behavior, then please try to figure how it
> could happens to me.
>
> I’m on Windows XP SP2, using max 457. My keyboard is a Korg Kontrol 49
> and it’s wired through USB2.
>
> f.e

#92993
Jan 11, 2007 at 10:45am

Hi f.e.

I can’t reproduce this on mac os 10.4.8, max 4.6.2

Is the midi interface on your soundcard or is it a separate device?

Good luck,
Mattijs

#92994
Jan 11, 2007 at 10:59am

On 11 janv. 07, at 11:09, f.e wrote:

> If you don’t have this behavior, then please try to figure how it
> could happens to me.

It works here (osx3.9, max457, novation mm10-x keyboard)

I don’t understand how the dsp can change your patch behavior, but
anyway I would never do a [sel 0] on a float.

_____________________________
Patrick Delges

Centre de Recherches et de Formation Musicales de Wallonie asbl

http://users.skynet.be/crfmw/max

#92995
Jan 11, 2007 at 11:38am

#92996
Jan 11, 2007 at 11:51am

works fine for me too.

OS X 10.4.8, MaxMSP 4.6.2 (PPC)

J.

#92997
Jan 11, 2007 at 12:00pm

#92998
Jan 11, 2007 at 3:01pm

#92999

You must be logged in to reply to this topic.