odd poke~ behaviour in m4l, working fine in when open in max…

Oct 31, 2011 at 3:48am

odd poke~ behaviour in m4l, working fine in when open in max…

hi there, getting back to an older issue which is still giving me stress.

I had posted earlier on this (http://cycling74.com/forums/topic.php?id=34746) but please pay this no mind (much obliged to leckerfisch for responding though), must have put the post together late at night, and foolishly said peek~ when i meant poke~.

So: the issue is this: i’m using poke~ to write a buffer. Works as expected when open in max, but when i close the m4l patch and run it in live, the last 1/10 or so of the buffer will not have anything written to it.

I attach a patch which shows this behaviour on my machine. Simply set the ms length, and the scope~ object shows the poke~ input, and the buffer displays the sample written. As i said, when i have it open in max it writes the full buffer. When closed and running in live, there is a gap of silence. Any ideas what might be causing this behaviour? Much obliged for any input…

http://lokeymassive.net/misc/poketest.amxd

#59698
Nov 2, 2011 at 2:41pm

so speaking with cycling support, and they can’t reproduce this behaviour. Very odd. I’ve tried this with two separate audiocards, at 44.1 and 48, still getting the gap in buffer recording when using the patch in in live, yet the buffer records through when open in max. Anyone experienced this before? Any ideas what could be causing it? Im at my wits end here…

#214852
Nov 3, 2011 at 1:38pm

Works perfectly for me with the mic input of the mac. Osx 10.5.8… Tried with various buffer lengths…

#214853
Nov 3, 2011 at 9:50pm

thanks, i somehow managed to shake things loose by going back in and reseting the buffer samplerate and bit depth to match with my live settings, but it’s odd because they should have been set to the same values all along.

Does anyone know how to go about observing the actual samplerate information of live?

#214854
Nov 4, 2011 at 8:05am

Except from the preferences panel, I don’t think you can access it through the api.

#214855
Nov 4, 2011 at 8:02pm

a chap on the monome forum suggested

‘try using dspstate i think with sr as an argument. should get the samplerate.’

i haven’t had a moment since then to try that out…

#214856

You must be logged in to reply to this topic.