Forums > Jitter

On overcoming "overlap noise"

February 24, 2007 | 5:23 pm

Hi,

So I’ve sorted out how to draw goodlooking 3d tri_strips with my tablet,
but I have a little problem:

When the pressure (which controls the Z value) reaches 1 it creates a
natural Z-plane, wherein a lot of the tri_strip resides. When this strip
has a fixed Z value the triangles that make up the strip tend to overlap
on the same z level, causing a fair bit of flickering when changing the
camera angle.

How can this best be resolved? I am considering adding a little bit of
noise to the z positioning data in order to place points behind each
other arbitrarily – is that the best way to go, or are there
easier/cheaper alternatives? Like a "Jitter, just effing pick one
vertex, please"-message.

Once I’ve cracked that, then this wacom-fiddling openGL patch will be
ready to share.

Thanks, you guys are awesome.
Andreas.


February 25, 2007 | 12:42 am

Andreas Wetterberg skrev:
> When this strip has a fixed Z value the triangles that make up the
> strip tend to overlap on the same z level, causing a fair bit of
> flickering when changing the camera angle.
>
> How can this best be resolved? I am considering adding a little bit of
> noise to the z
haha, once again I end up answering myself… I gotta stop doing that :)
Adding a tiny bit of noise did solve my problem – my setting right now
is adding a random value around 0.0001-0.0007 to each input, which isn’t
visible (in my patch) but good enough to separate the strip edges.

Andreas.


Viewing 2 posts - 1 through 2 (of 2 total)