open gl antialias problems

Mar 2, 2007 at 2:08pm

open gl antialias problems

i’m having difficulty trying to get the antialiasing to work with open gl objects in jitter 1.63b2…

i’m running on a mbp 2.16 / ati radeon x1600 256 ram and i have a patch with jit.gl.render and gridshape objects with blend_enable, antialias 1, fsaa 1 attributes. however i dont see any antialiasing occuring on the open gl shapes (eg. jagged edges at an angle).

i managed to get this to work fine when using jitter 1.24, but cant seem to get anywhere in jitter 1.5.

what attributes do i need to set to enable the antialiasing?
i understand that on “some graphics cards” u need blend enable on… are there any other settings i should be aware of for my graphics card?

(can post example patch if needed)

thanks,

j

#30584
Mar 2, 2007 at 5:02pm

On Mar 2, 2007, at 2:08 PM, justin wrote:

> i’m running on a mbp 2.16 / ati radeon x1600 256 ram and i have a
> patch with jit.gl.render and gridshape objects with blend_enable,
> antialias 1, fsaa 1 attributes. however i dont see any antialiasing
> occuring on the open gl shapes (eg. jagged edges at an angle).

fsaa 1 to jit.window or jit.pwindow.

“antialias” is only for line antialiasing, so it doesn’t do anything
for filled polygons.

-Joshua

#97972
Mar 2, 2007 at 6:23pm

Quote: jkc wrote on Fri, 02 March 2007 17:02
—————————————————-
>
> On Mar 2, 2007, at 2:08 PM, justin wrote:
>
> > i’m running on a mbp 2.16 / ati radeon x1600 256 ram and i have a
> > patch with jit.gl.render and gridshape objects with blend_enable,
> > antialias 1, fsaa 1 attributes. however i dont see any antialiasing
> > occuring on the open gl shapes (eg. jagged edges at an angle).
>
> fsaa 1 to jit.window or jit.pwindow.
>
> “antialias” is only for line antialiasing, so it doesn’t do anything
> for filled polygons.
>
> -Joshua
>
>
>
—————————————————-

ok, works now. i was sending fsaa to both jit.render and jit.window and didnt work… now if i send it just to jit.window it works… (?)

i was expecting both of them would need to have it enabled for it to work.

and just to dbl check i understand antialias properly, antialias $1 is for objects drawn in line primitive or in poly_mode 1 1.

so fsaa will not anti alias objects drawn as lines?

thanks. j

ps. any news on the next jitter beta?

#97973
Mar 2, 2007 at 6:33pm

On Mar 2, 2007, at 6:23 PM, justin wrote:

> and just to dbl check i understand antialias properly, antialias $1
> is for objects drawn in line primitive or in poly_mode 1 1.
>
> so fsaa will not anti alias objects drawn as lines?

It will. FSAA is “Full Scene Anti-Aliasing”, which may or may not be
as nice looking or as fast as line based anti-aliasing (sometimes not
supported anyway, and sometimes it might be slower depending on how
many lines are being rendered).

> ps. any news on the next jitter beta?

See last mail to the list. Will try to squeeze some Jitter dev time
in soon, but can’t say exactly when.

-Joshua

#97974
Mar 2, 2007 at 6:46pm

cheers!

#97975
Mar 3, 2007 at 2:15pm

one last question!

how come when i have fsaa set to 1 on the jit.window, i lose the erase_color alpha trails?

seems the only way i get them back is by setting the window to doublebuffer 0… i’m trying to understand why this would happen?
blend_enable is set to 1.

j

#97976
Mar 3, 2007 at 3:30pm

On Mar 3, 2007, at 2:15 PM, justin wrote:

> how come when i have fsaa set to 1 on the jit.window, i lose the
> erase_color alpha trails?
>
> seems the only way i get them back is by setting the window to
> doublebuffer 0… i’m trying to understand why this would happen?
> blend_enable is set to 1.

Just the way the multi-sampling is implemented w/r/t the draw buffer.
You might be able to do something clever if you copy to a texture and
render a quad with this texture before the rest of the scene, but it
will be a litte bit annoying to implement. Check out some of Andrew’s
recipes. I think there’s one with texture feedback.

-Joshua

#97977
Mar 3, 2007 at 9:17pm

Ive tried this workaround, and at least on my system I could not get
that to work. I even attempted to toggle fsaa on / off at the
beginning /end of my render chain, to no avail. Ill look at it again
and see if I can crack it, because it would be super sexy. I too was
majorly sad when loosing the ‘trails’ effect of low alpha erase color.

On Mar 3, 2007, at 10:30 AM, Joshua Kit Clayton wrote:

>
> On Mar 3, 2007, at 2:15 PM, justin wrote:
>
>> how come when i have fsaa set to 1 on the jit.window, i lose the
>> erase_color alpha trails?
>>
>> seems the only way i get them back is by setting the window to
>> doublebuffer 0… i’m trying to understand why this would happen?
>> blend_enable is set to 1.
>
> Just the way the multi-sampling is implemented w/r/t the draw
> buffer. You might be able to do something clever if you copy to a
> texture and render a quad with this texture before the rest of the
> scene, but it will be a litte bit annoying to implement. Check out
> some of Andrew’s recipes. I think there’s one with texture feedback.
>

v a d e //

http://www.vade.info
abstrakt.vade.info

#97978
Mar 3, 2007 at 9:46pm

vade skrev:
> I too was majorly sad when loosing the ‘trails’ effect of low alpha
> erase color.
>
I hope I’m not veering to much off-topic, but that trails effect got old
for me really quickly… anyone? Am I just a ‘tard right now?

Andreas.

#97979
Mar 4, 2007 at 12:11am

depends what you do with it. if you render to texture, and then apply
slab processing the erase_color with low alpha becomes VERY
interesting and adds a much much more organic feel to things, in my
opinion, its a tool and can be very useful if you know how to use it
and experiment with it.

On Mar 3, 2007, at 4:46 PM, Andreas Wetterberg wrote:

> I hope I’m not veering to much off-topic, but that trails effect
> got old for me really quickly… anyone? Am I just a ‘tard right now?

v a d e //

http://www.vade.info
abstrakt.vade.info

#97980
Mar 4, 2007 at 11:20am

> Just the way the multi-sampling is implemented w/r/t the draw buffer.
> You might be able to do something clever if you copy to a texture and
> render a quad with this texture before the rest of the scene, but it
> will be a litte bit annoying to implement. Check out some of Andrew’s
> recipes. I think there’s one with texture feedback.
>
> -Joshua
>
—————————————————-

that sounds like way too much work… ; )

but i enjoyed andrew’s recipies, very tasty if not a little heavy to digest!

on the other hand i think i managed to fix it by turning off the doublebuffer and depthbuffer on the jit.window!

so i now have it all fsaa, and blend_enable alpha trails. all i need now are some decent hallucinogenics, anyone?

#97981
Mar 4, 2007 at 11:24am

Quote: vade wrote on Sun, 04 March 2007 00:11
—————————————————-
> depends what you do with it. if you render to texture, and then apply
> slab processing the erase_color with low alpha becomes VERY
> interesting and adds a much much more organic feel to things, in my
> opinion, its a tool and can be very useful if you know how to use it
> and experiment with it.

yeah agreed, can look very “old”… but as vade points out, its all in how u use it. i found using blend modes can create some interesting feedback fx with alpha trails.

j

#97982
Mar 4, 2007 at 1:34pm

justin skrev:
> one last question!
>
> how come when i have fsaa set to 1 on the jit.window, i lose the erase_color alpha trails?
>
> seems the only way i get them back is by setting the window to doublebuffer 0… i’m trying to understand why this would happen?
> blend_enable is set to 1.
Hi Justin,
on my system (xp, jitter 1.63b2, Geforce 8800 gts) your jit.window can
be modified to
[jit.window context @depthbuffer 1 [....] @floating 1 @doublebuffer 1
@fsaa 1 @sync 1]
- without problems.

Just in case I misread your post I grabbed a screenshot to check if I
got this right:

Jitter fsaa test

I hope this helps.
Andreas.

#97983
Mar 4, 2007 at 2:46pm

[ot]
andreas how is the 8800 doing!

On 3/4/07, Andreas Wetterberg wrote:
>
> justin skrev:
> > one last question!
> >
> > how come when i have fsaa set to 1 on the jit.window, i lose the
> erase_color alpha trails?
> >
> > seems the only way i get them back is by setting the window to
> doublebuffer 0… i’m trying to understand why this would happen?
> > blend_enable is set to 1.
> Hi Justin,
> on my system (xp, jitter 1.63b2, Geforce 8800 gts) your jit.window can
> be modified to
> [jit.window context @depthbuffer 1 [....] @floating 1 @doublebuffer 1
> @fsaa 1 @sync 1]
> – without problems.
>
> Just in case I misread your post I grabbed a screenshot to check if I
> got this right:
> http://www.flickr.com/photos/18877453@N00/409877124/
>
> I hope this helps.
> Andreas.
>

#97984
Mar 4, 2007 at 3:36pm

> Hi Justin,
> on my system (xp, jitter 1.63b2, Geforce 8800 gts) your jit.window can
> be modified to
> [jit.window context @depthbuffer 1 [....] @floating 1 @doublebuffer 1
> @fsaa 1 @sync 1]
> – without problems.

yeah sorry forgot to mention, i think it works fine with doublebuffer on windows machines, but not on osx… ; )

i only have a mac to test this on at the mo!

j

#97985
Mar 4, 2007 at 9:07pm

yair reshef skrev:
> [ot]
> andreas how is the 8800 doing!
Well, to be honest I’m having a lot of trouble even benchmarking it – I
have a 1680×1050 + 1280×1024 screen setup here, and I get 52-60 fps with
most openGL patches that I span across them…!

I haven’t ventured far enough into all the exotic branches of GL to
really push it, but I have made patches that generate thousands (!) of
planes swirling into 3d space using .Sketch at 1680*1050, while
retaining high fps values.

I would love it if someone had some tricky stuff to try out!
Andreas

#97986

You must be logged in to reply to this topic.