Open patcher without menu bar

Sep 28, 2010 at 10:22pm

Open patcher without menu bar

Hi, I feel like this question must be answered somewhere, but I can’t find the answer:

How do you open a patcher without a menu bar? Basically, something like the “About Max” window. I am trying to make a settings window for my program, and I want it to pop up without the menu bar, because that’s quite unnecessary. I’ve also found that unchecking “Show Toolbar on Open” in the patcher’s inspector does not actually hide the toolbar when I open it.

BTW I am using the “open” message to [pcontrol], which is connected to my settings subpatcher. Using Windows.

#52509
Sep 28, 2010 at 10:38pm

hi,

I remember a “nomenu” message to thispatcher in the thispatcher help patch…

g

#188833
Sep 28, 2010 at 11:15pm

Thanks! That’s what I was looking for.

I also figured out the answer to the second part of my question: I simply needed to re-load the top level patch in order for toolbar to be hidden in the subpatch.

#188834
Sep 29, 2010 at 9:45pm

I wanted to post a follow up to this, because there seems to be a problem associated with it. When I send [thispatcher] the message “window flags nomenu, window exec, savewindow 1,” I get a Max window error “method bringtofront called on invalid object when I restart the patch.” I can avoid the error by sending “savewindow 0,” but then it will show the menu.

Presumably that is a bug? Is the best option to simply loadbang the nomenu message to [thispatcher], rather than saving the window?

#188835
Sep 29, 2010 at 9:57pm

Hi Anthony,

I can’t repro here with a simple patch. Is there perhaps something else going on in your patch?

-Ben

#188836
Sep 30, 2010 at 12:21am

Hi, I can recreate it in a very simple patch:

– Pasted Max Patch, click to expand. –

Please paste this into a new patcher window, click the message box, save the patcher to disk, close it AND restart Max, then open it again. Note that it only happens if you close Max entirely, i.e. you don’t just close the patch, but also close the Max window and other patchers running.

I’m using Windows 7 64-bit, 5.1.5.

#188837
Sep 30, 2010 at 4:35pm

Hi Anthony,

Thanks for the clarification. I can only get this to happen when launching Max from the patch. This is a harmless error and can be ignored. It should not happen under other circumstances, say, when you open Max first or in a standalone.

If it really is bumming you out, then a loadbang might be the best way to go at this time.

-Ben

#188838
Sep 30, 2010 at 5:08pm

Moderate bummage, but I think I can manage. :)

#188839
Sep 30, 2010 at 7:05pm

One last question:

I sent the nomenu message to my toplevel patcher as well, but when I make it into a standalone, the Max Runtime window appears on startup, even though I have that option unchecked in [standalone]. Is there any way around that?

#188840
Sep 30, 2010 at 7:17pm

Hi Anthony,

This was actually programmed like this by design. On Windows, if there is no menu then you cannot do anything. So, when max is launched if there are no windows that have a menu, Max always shows the max window to give the user a chance to do something.

However, it has come up a few times and thus we do have this issue as something to look at down the road.

A workaround is to add a deferlow between the loadbang and the window message box.

Apologies for the inconvenience.

-Ben

#188841
Sep 30, 2010 at 7:30pm

That works perfectly, thank you so much for all of your help.

#188842
Dec 11, 2010 at 7:36pm

thanks for the workaround !

o.

#188843
Mar 28, 2012 at 1:19am

Running max 6 over here. I have a project that I want to use with runtime. I can’t get it to run without the toolbar. Could someone please spell it out for me? I have yet to find the right permutation and the client I developed this for just decided they don’t want to use display out for their monitor… which was cake to set up. Is the message different on a mac?

– Pasted Max Patch, click to expand. –

What would be the equivalent of this for Mac? Would the thispatcher need to be in a patcher?

#188844
Mar 28, 2012 at 2:48am

did you try View menu-> Patcher inspector-> deselect ‘view toolbar’ checkbox…?

#188845
Mar 30, 2012 at 12:51am

Thank you for the suggestion. Unfortunately, it does not work :(

#188846

You must be logged in to reply to this topic.