Forums > Jitter

OpenGL issue, WinXP Max 5.05

October 7, 2008 | 7:06 am

I’m working on dev project that makes extensive use of particles in a GL context. We are developing on XP systems due to a client limitation.

We’ve run into an issue that seems to only appear on Win32 systems – the identical code running on a Mac does not throw any errors. When the code is run under XP the Max window is full of the following error:

jit.gl.texture: error binding texture to target: GL Error: Invalid operation

I can confirm that this has been tested on multiple XP machines, using both nVidia and ATI graphics cards. The error is consistent across all of them. I have a MacBook with bootcamp and the code runs as expected on identical hardware under OSX, but throws the errors in XP.

The code runs without error on both OSX and XP under Max 4.6.

I’ve attached example code as a zip archive. Any insight would be much appreciated.


May 26, 2009 | 11:19 am

I’m experiencing the same error with Max 5.07 in circumstances detailed below.

On win XP SP2 running on a macbook pro
I have a dual display (the screen of the macbook pro and an other connected with DVI/VGA adapter)

I’m using the jit.gl.slab.maxhelp file.
When I run the patch with the jit.window not in fullscreen, it works perfectly.

When I send the fullscreen 1 message to the jit.window :
- if it’s a fullscreen on the macbook pro display, it works
- if it’s a fullscreen on the other display it renders a white screen and the errors are :
jit.gl.texture : error bending texture to target : GL error : Invalid enumeration
jit.gl.texture : error enabling texture target : GL error : Invalid enumeration
jit.gl.texture : error setting texture wrap mode s : GL error : Invalid enumeration
jit.gl.texture : error setting texture wrap mode t : GL error : Invalid enumeration
jit.gl.texture : error setting texture filter mode. : GL error : Invalid enumeration
jit.gl.texture : error setting texture priority. : GL error : Invalid enumeration
jit.gl.texture : unable to create texture!
jit.gl: invalid extension called

I’ve tried unsuccessfully to use a jit.gl.texture object instead of sending the slab output to a videoplane.

Is there a way to render properly in fullscreen ?
Is it a specific / windows / driver bug ?

Thanks for your help.


May 26, 2009 | 11:55 am

hi,
ye.. i was having similar issues going to fullscreen in the second display, but i was getting diferent error message, something like my opengl version was too old and that i will have imparied bla bla… and then the frame rate falls down and down..

i never get this message going to fullscreen in the main monitor,
and also going in the secundary monitor to fullscreen dont give me always the imparied error, sometimes yes sometimes no…
i was writing direct to cycling but they dont give me a solution,
so at the end i begin to use rect message to jitwindow instead of fullscreen and with this i never get an error… you can get the coords of rect using jit.display, so you can adapt automatically to diferent resolutions of the displays to get a fullcreen rectangle.

my graph card is a 4870 ati radeon with opengl version 2.1 updated drivers and xp 64bits with max5

good luck!
o


Viewing 3 posts - 1 through 3 (of 3 total)