Forums > Jitter

OpenGL stability issue / freezes / Crashes

October 4, 2012 | 6:54 am

Since a few weeks I have quite a lot of OpenGL crashes (MBP 10.6.8, Max 6.0.7)
I’m not sure what causes them but it feels related to these posts:
http://cycling74.com/forums/topic.php?id=42767

http://cycling74.com/forums/topic.php?id=42536

For me it happen mostly when opening Gl objects help file +/- copy/paste elements into the patch I’m working on.
When I don’t add/delete any GL objects, everything is fine.

Symptoms:
Freeze and/or very glitchy window output.
Patche freeze, I can’t save/edit/change mode.
Message: jit.gl.fbo: unsupported framebuffer format.

I don’t have patch to demonstrate but I will try to make one.

Does anyone has this kind of problems ?

Thanks


October 4, 2012 | 7:07 am

yes,
it’s the same thing as http://cycling74.com/forums/topic.php?id=42632
but with me it’s never fine, whith a few slabs in my patch everything tends to freeze and crash big time, most of the time this means restart the whole computer

Pieter


October 4, 2012 | 7:25 am

6.0.8 soon ?
;)


October 4, 2012 | 3:09 pm

hi guys. thanks for the reports.
we think we know what’s going on here, and will do our best to get you a fix as soon as possible.

thanks for your patience.


October 5, 2012 | 7:12 am

that’s great news!!
On a pure selfish note, I have a performance in 3 weeks, should I start addapting patches to get rid of all things slab/capture. Or is a fix on the horizon?

pieter


October 5, 2012 | 7:29 am

i think these crashes are related to deleting jit.window or jit.pwindow.

if you can describe another scenario where this crash occurs that doesn’t involve deleting a opengl window, it would be much appreciated if you can provide a patch and instructions to reproduce.



dtr
October 5, 2012 | 7:54 am

For me it’s that: deleting a jit.pwindow or closing a patch with one in it.


October 5, 2012 | 7:24 pm

If we include "closing another patch with a pwindow in it", it is the case for me.
The annoying point is that most of the help files have one ;)


October 5, 2012 | 8:42 pm

yes, should’ve been more specific.

from what i’ve been able to determine, the crash results when you have a patch with some kind of texture object (jit.gl.slab, gl.texture, gl.node, etc), and you free a pwindow or window object (either by deleting or by closing a patch).

thanks again for the reports, and we’ll get a fix as soon as possible.


October 15, 2012 | 2:12 am

just offhand posting in the few threads related to this as I find them (they touch on slightly different angles) – editing a patch w/ gl.slab + gl.texture (not just deleting or freeing windows) does it for me. thanks for your work on solving this!



pry
October 17, 2012 | 6:31 pm

Exactly the same troubles and messages, but even without editing : just let run a patch w/ jit.gl.slab, jit.gl.node a few moments and it crashes !


Viewing 11 posts - 1 through 11 (of 11 total)