OpenGL Sync flicker problem with rotated screen

Jul 30, 2009 at 10:58am

OpenGL Sync flicker problem with rotated screen

Hi there,

does anybody have an idea why this appears:
When using certain nvidia cards (I tested three different brands now but all nVIDIA) there are problems with sync when the screen is rotated. 90 deg or 180 deg doesn’t make a difference.
OpenGL fullscreen shows an area that isn’t sync (see attached photo).
I’m using the latest drivers (same forceware) for both of them.
The problem appeared on a 9500GT, a 8400GS and same on a QuadroFX4500.
Only on two Geforce 8600 cards (different brands) the problem doesn’t appear.
All tested in one PC with the newest drivers (6.14.11.9038).

Thanks

seccoindex.php?t=getfile&id=3219&private=0

#44956
Jul 30, 2009 at 7:23pm

you’re saying when you rotate the actual physical monitor?
does it happen with any other opengl applications (or any other application in general)?

did you try enabling sync on your jit.window?

sounds like a monitor issue. i just tested with my nvidia 8800 and didn’t experience any tearing.

#161908
Jul 31, 2009 at 10:09am

Hi robtherich,

-I tried three different monitors with the same result
-It only appears when rotated (90, -90 or 180 same result)
-Without rotation everything is fine.
-sync flag for jit.window or jit.gl.render doesn’t make a difference
-Any other OpenGL-Application shows this result. Not only Max/Jitter.
-It also appears when not in fullscreen but the area is smaller then. The larger the OpenGL-window, the larger the tearing area

#161909
Aug 3, 2009 at 4:52pm

I hate to say it, but if other OpenGL apps are showing the same behavior then it’s likely a driver/OS issue and nothing we do to Jitter will be able to fix it.

wes

#161910
Aug 4, 2009 at 9:26am

Hi wes,

I know, I was just wondering if anybody else here had the same problem and maybe already found a solution. I’m also in contact with nVIDIA technical support but they are really slow.

regards
secco

#161911

You must be logged in to reply to this topic.