Forums > Jitter

OpenGL to Matrix and other Q's.

May 20, 2009 | 5:58 pm

I’m working on a music visualizer (It’s already working and done)that uses many gl.gridshapes and gl.graphs. I want, however to blend/mix various other material (qt movies, images, etc) over it…kind of like if my OpenGL rendering were a qt.movie itself and I could fade in and overlay other stuff.

I have searched the forums and saw people recommending jit.gl.asyncread. to rending the GL to a matrix…It seems however that in order for that matrix to look nice/not pixelated fullscreen, your OGL window has to be fullscreen as well (If it’s not, and I fullscreen the matrix window, all the objects are super pixelated). Having a matrix and the gl.render fullscreen at the same time brings my MBP to a crawl.

Is there anyway to access my gl.render in perfect quality and overlay .mov’s or images? What does the enable matrix output attribute of the jit.gl.render do? Is that what I need?


May 21, 2009 | 4:03 pm

you can mix in videos with jit.gl.videoplane. You’ll probably want to set depth_test to 0 and blend_enable to 1 while varying the alpha in the color message.

wes



efe
May 21, 2009 | 5:22 pm

I found myself in a similar situation some weeks ago, I had a live cinema piece where I was switching between some GL objects and a video plane running pre-render material. At the beginning I was enabling and disabling the objects using the enable attribute but I found, with a big surprise, that the cpu was still overloaded. The solution I came with was to stop sending bangs to the objects at the same time I disabled them, this way I was able to switch between the 3d objects and the movies.
Hope it helps!
Emmanuel


May 21, 2009 | 10:16 pm
efe wrote on Thu, 21 May 2009 13:22
I found myself in a similar situation some weeks ago, I had a live cinema piece where I was switching between some GL objects and a video plane running pre-render material. At the beginning I was enabling and disabling the objects using the enable attribute but I found, with a big surprise, that the cpu was still overloaded. The solution I came with was to stop sending bangs to the objects at the same time I disabled them, this way I was able to switch between the 3d objects and the movies.
Hope it helps!
Emmanuel

So I just do a gl.videoplane in fullscreen on my render and mess with the transparency?



efe
May 22, 2009 | 5:16 am

No, that won’t help. Of course you can use the transparency in order to make transitions, but if you want to save cpu you need to disable the objects that you don’t want to use and stop sending bangs to them. The way I did it was by using an if conditional together with an umenu. I am not at home now but I will try to post an example later.
Good luck!
Emmanuel


May 22, 2009 | 4:33 pm

Depending on whether you want your movie playing in front or behind the OpenGL geometry, you can set the @layer attributes for your objects for an easy way to define rendering order. Higher layers will be rendered in front of (after) lower layers. Changing the alpha color (w/ @blend_enable 1) will give you transparency. You can also use various keying techniques to show only parts of your video.

Best,
Andrew B.


October 31, 2009 | 10:50 pm

Is it possible to know how to get a mix between jit.gl objects and jit.qt.movie or grab??
I need to mix a jit.qt.grab, after the effect jit.brass with a jit.gl.videoplane or jit.gl.render object.
Thank you very much for your help.

Visualpaco


December 1, 2010 | 2:16 pm

Hello,

I am trying to use the 0.Glfo patch (recipe 1 ) to animate some videoplanes with blend_enable on.
It works well but when I add a another videoplane as background, only one videoplane is visible, the other ones are still animated but behind my videoplane background. Is there any way to get them all on top of a background or other videoplanes layers.. ?

Many Thanks

– Pasted Max Patch, click to expand. –

Viewing 8 posts - 1 through 8 (of 8 total)