Forums > MaxMSP

opening posted .txt patches

April 4, 2007 | 3:57 am

Hi List,

I’m running 4.5.1 – is there no way I can open patches made with newer versions of Max/MSP, it seems most people on here have a newer version.

I’ve been adding max v2; at the top and #P pop; at the bottom of saved txt files but it rarely works – either get the typical error or an open text file.

I’ve briefly looked thru the archives and but found no info other than – apparently there IS a way to do it – but its hard.

thanks


April 4, 2007 | 9:08 am

Can you open text files you created by yourself? What happens if you paste the text straight into the patcher window?


April 4, 2007 | 11:19 am

yeah, anything i’ve saved is fine – and some patches from the forum are fine as well – eg. in the recent posts – if the text file already has the ‘max v2;’ and ‘#P pop;’ it will open fine – but if it doesn’t it will open sometimes (more often not) if I add those prefix and suffix.

even if it is from the same user – I can open the patch posted by leafcutter john in the ‘buffer creation via scripting’ thread but not the patch he posted in the ‘groove~ sync mental challenge’ thread.

Also I don’t know what you mean by pasting the text straight into the patcher window – tried opening a new patch and doing that – but nothing.

thanks


April 6, 2007 | 8:50 am

On 4 avr. 07, at 13:19, pechnatunk wrote:

> yeah, anything i’ve saved is fine – and some patches from the forum
> are fine as well – eg. in the recent posts – if the text file
> already has the ‘max v2;’ and ‘#P pop;’ it will open fine – but if
> it doesn’t it will open sometimes (more often not) if I add those
> prefix and suffix.
>
> even if it is from the same user – I can open the patch posted by
> leafcutter john in the ‘buffer creation via scripting’ thread but
> not the patch he posted in the ‘groove~ sync mental challenge’ thread.
>
> Also I don’t know what you mean by pasting the text straight into
> the patcher window – tried opening a new patch and doing that –
> but nothing.

Upgrade to 4.5.7 or 4.6.2 (unless you have a performance tonight).
There’s a lot of improvements and it’s a free update. Then you can
use the "New from clipboard" command.

ej


April 7, 2007 | 12:25 pm

pechnatunk schrieb:
> I’m running 4.5.1 – is there no way I can open patches made with
> newer versions of Max/MSP, it seems most people on here have a newer
> version.

> I’ve briefly looked thru the archives and but found no info other
> than – apparently there IS a way to do it – but its hard.

But the update is free, for 4.5.1. Or do you need arguments to buy a
license? There are student discounts by the way…

And I can tell you that every penny was invested well at least in my
case… ;-)

You’re welcome

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


Viewing 5 posts - 1 through 5 (of 5 total)