OSC works intermittently

Jan 29, 2013 at 7:18pm

OSC works intermittently

Hey guys,

I’ve been working on translating OSC data into Midi notes.

What I have at the moment is a very simple system that just takes an integer from a button within Lemur and that transmits into the pitch inlet of make note.

The problem I’m having is, either OSC wont work for ages but then suddenly will. OR if it works for a while, if i close the patcher window and return to Ableton the device stops receiving data.

Any ideas why this is happening? Is it Max related or do you think its a problem with the wireless network?

Cheers

Wilbur

P.s. This uses CNMATS OSC bundle so you’d need that for the system to work.

– Pasted Max Patch, click to expand. –
#66278
Jan 29, 2013 at 7:25pm

remove the external from the equation, then try again. You can use the normal [route] to route OSC.

Also, iPad lemur or native? Bluetooth network? Ad hoc? Shared? What’s your specs?

#238569
Jan 30, 2013 at 12:25am

> if i close the patcher window and return to Ableton the device stops receiving data.

It’s a known issue that has been discussed on this thread

http://cycling74.com/forums/topic.php?id=36165

#238570
Jan 30, 2013 at 1:36am

ah yes, that old chestnut – I have the same thing going on. IF this is the case you should easily be able to see messages NOT coming in with a strategically placed message box. And in that thread above I outline how I’ve solved it in the past.

#238571

You must be logged in to reply to this topic.