Forums > MaxMSP

[ot] OS X Network Live Routing question

March 14, 2008 | 3:01 am

Sorry for the off-topic post, but I’m soliciting help from the generally geeky population that is the MaxMSP user base. :)

I posted the following message to three different discussion groups on the Apple support site, and now weeks later have still received 0 replies on any of them, which makes me wonder "Is ANYBODY using the Network MIDI feature of Mac OS 10.4+?" I’m using it, and it works fine with an application such as MaxMSP, but so far even though I appear to be doing everything correctly, I can’t get the "Live Routing" feature of it to work (i.e. to route MIDI directly to/from the Network and to/from and external device, without using a routing application such as MaxMSP). Given that I can find NO online discussion of this feature by anyone who has actually used it, I’m wondering if it even works at all. If you have any experience with this, I’d be happy to hear from you. Here’s the post:

I am working with the Network MIDI feature of OS X Tiger. I am able to connect two computers just fine, and send MIDI back and forth (with pleasantly surprisingly little latency) between applications on the two computers. However, the "Live Routing" feature of the Network MIDI dialog is not yet working for me, and I wonder if I’m understanding it correctly. Say, for example, that I have a Motif synthesizer attached to one computer (and identified as a device in its Audio-MIDI Setup) and a K2500 synthesizer on the other computer (identified as a device in that computer’s Audio-MIDI Setup). It seems intuitively that on the first computer, in the Live Routing area I should specify the Motif as sending to the Network (i.e. to the globe icon, which I interpret to mean "out to the network") and the globe icon sending to the Motif (which I interpret to mean "coming in from the network"), and likewise on the second computer specify the K2500 as sending to the globe icon and the globe sending to the K2500. That should mean that if I play in the Motif, the MIDI should go straight out on the network and be played directly on the K2500 with no further ado (without passing it through an application), and vice versa. However, that does not work for me (the direct "live routing" of one synth to another), even though I can see that the MIDI is getting from one computer to the other. SO, my question is: Am I interpreting this correctly, and am I "live routing" the MIDI properly from one synth to another, or do I need to do something different? (As I said, it seems like that’s what those icons mean, but I’m not getting that result.) Any advice would be welcome. Thanks in advance! –Chris



waj
March 27, 2008 | 3:55 pm


Viewing 2 posts - 1 through 2 (of 2 total)