Forums > MaxMSP

p5 dataglove on mac intel…..


MJ
October 17, 2007 | 2:49 am

hi list

anyone got the p5 dataglove to work on mac intel ?
download the new p5osc and new opensoundcontrol object
but still no luck

even mailed Tim Kreger
he told me to reinstall or ask the maxlist cause some maxers got it working according to him.

i download dumpOSC to test it (http://www.cnmat.berkeley.edu/OpenSoundControl/dumpOSC.html)
works fine on g4 but on intel it says

[ 100000000000000
*** ERROR: Bad size count 1275068416 in bundle (only 76 bytes left in
entire bundle)

i use this patch to test it in max
works great on G4 but again not on intel….

#P user gswitch2 179 314 39 32 1 0;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 211 356 50 196617 print hop;
#P newex 90 250 103 196617 route /p5glove_data;
#P newex 61 197 90 196617 OpenSoundControl;
#P user gswitch2 77 95 39 32 0 0;
#P newex 109 137 50 196617 print poh;
#P newex 39 54 128 196617 udpreceive 47110 CNMAT;
#P connect 2 1 1 0;
#P fasten 0 0 2 1 44 80 82 80 111 80;
#P connect 6 1 5 0;
#P connect 4 0 6 1;
#P connect 3 1 4 0;
#P connect 2 0 3 0;
#P window clipboard copycount 7;

anyone?…

-MJ


October 17, 2007 | 1:17 pm

I’m having no trouble at all. For whatever it’s worth, I don’t use
the CNMAT second argument in my udpreceive object.

Do you see data in the terminal if you use the -d option with p5osc?

M

On Oct 16, 2007, at 22:49, MJ wrote:

>
> hi list
>
> anyone got the p5 dataglove to work on intel ?
> download the new p5osc and new opensoundcontrol object
> but still no luck
>
> even mailed Tim Kreger
> he told me to reinstall or ask the maxlist cause some maxers got it
> working according to him.
>
> i download dumpOSC to test it (http://www.cnmat.berkeley.edu/
> OpenSoundControl/dumpOSC.html)
> works fine on g4 but on intel it says
>
> [ 100000000000000
> *** ERROR: Bad size count 1275068416 in bundle (only 76 bytes left in
> entire bundle)
>
> i use this patch to test it in max
> works great on G4 but again not on intel….
>
> #P user gswitch2 179 314 39 32 1 0;
> #P window setfont "Sans Serif" 9.;
> #P window linecount 1;
> #P newex 211 356 50 196617 print hop;
> #P newex 90 250 103 196617 route /p5glove_data;
> #P newex 61 197 90 196617 OpenSoundControl;
> #P user gswitch2 77 95 39 32 0 0;
> #P newex 109 137 50 196617 print poh;
> #P newex 39 54 128 196617 udpreceive 47110 CNMAT;
> #P connect 2 1 1 0;
> #P fasten 0 0 2 1 44 80 82 80 111 80;
> #P connect 6 1 5 0;
> #P connect 4 0 6 1;
> #P connect 3 1 4 0;
> #P connect 2 0 3 0;
> #P window clipboard copycount 7;
>
>
> anyone?…
>
>
> -MJ
>
>


October 17, 2007 | 10:01 pm

Quote: news wrote on Wed, 17 October 2007 06:17
—————————————————-
> I’m having no trouble at all. For whatever it’s worth, I don’t use
> the CNMAT second argument in my udpreceive object.
>
>

What is your computer; I think this is an intel-specific problem.

mz


October 18, 2007 | 6:23 pm

it’s an intel — but I’m not having any problems……

M

On Oct 17, 2007, at 18:01, mzed wrote:

>
> Quote: news wrote on Wed, 17 October 2007 06:17
> —————————————————-
>> I’m having no trouble at all. For whatever it’s worth, I don’t use
>> the CNMAT second argument in my udpreceive object.
>>
>>
>
> What is your computer; I think this is an intel-specific problem.
>
> mz
>
>
>
> –
> || michael f. zbyszynski — molecular gastronimist
> || http://www.cnmat.berkeley.edu/
> || http://www.mikezed.com/
>
>
>


October 18, 2007 | 8:13 pm

Quote: news wrote on Thu, 18 October 2007 11:23
—————————————————-
> it’s an intel — but I’m not having any problems……
>

Strange. On both my intel Macs I’m getting bad size count errors.

p5osc -d dumps well in the terminal, but the actual OSC packets have a bad size. I’ve verified this in Max and with dumpOSC.

I’ve got an Intel iMac and a Macbook Pro, both running OS 10.4.10.

mz


October 18, 2007 | 8:38 pm

On 17 oct. 07, at 04:49, MJ wrote:

> [ 100000000000000
> *** ERROR: Bad size count 1275068416 in bundle (only 76 bytes left in
> entire bundle)

Same problems here on Macbook Pro…

Roby


October 18, 2007 | 9:35 pm

Quote: Roby Steinmetzer wrote on Thu, 18 October 2007 13:38
—————————————————-
>
> On 17 oct. 07, at 04:49, MJ wrote:
>
> > [ 100000000000000
> > *** ERROR: Bad size count 1275068416 in bundle (only 76 bytes left in
> > entire bundle)
>
> Same problems here on Macbook Pro…
>
> Roby
>
—————————————————-

I found a problem where the endianness isn’t set correctly. I’ve successfully built a version that works for me on my Macbook Pro.

I’ll check with Tim to see if we can get this fixed.

mz


October 18, 2007 | 10:24 pm

On 18 oct. 07, at 23:35, mzed wrote:
> I found a problem where the endianness isn’t set correctly. I’ve
> successfully built a version that works for me on my Macbook Pro.
>
> I’ll check with Tim to see if we can get this fixed.

Thanks,
Roby


October 18, 2007 | 10:49 pm

Please let us know here if you do get it fixed – I’ve had no luck
with my p5 (on my macbook pro) either.

thanks

David

On 18 Oct 2007, at 23:24, Roby Steinmetzer wrote:

>
> On 18 oct. 07, at 23:35, mzed wrote:
>> I found a problem where the endianness isn’t set correctly. I’ve
>> successfully built a version that works for me on my Macbook Pro.
>>
>> I’ll check with Tim to see if we can get this fixed.
>
> Thanks,
> Roby


October 18, 2007 | 11:30 pm

Quote: david stevens wrote on Thu, 18 October 2007 15:49
—————————————————-
> Please let us know here if you do get it fixed – I’ve had no luck
> with my p5 (on my macbook pro) either.
>

No guarantees:

http://www.mikezed.com/p5osc.zip

Put this in /usr/local/bin/

mz



MJ
October 19, 2007 | 12:06 am

it says :

ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/macosx_usb_hid.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/main.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/IpEndpointName.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/NetworkingUtils.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/UdpSocket.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscOutboundPacketStream.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscPrintReceivedElements.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscReceivedElements.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscTypes.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscReceiveTest.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscSendTests.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/OscUnitTests.ob
ZeroLink: could not load .o file:
/Users/mzed/CNMAT/Code/trunk/devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-normal/i386/p5glove.ob

-mj

>Quote: david stevens wrote on Thu, 18 October 2007 15:49
>—————————————————-
>> Please let us know here if you do get it fixed – I’ve had no luck
>> with my p5 (on my macbook pro) either.
>>
>
>No guarantees:
>
>http://www.mikezed.com/p5osc.zip
>
>Put this in /usr/local/bin/
>
>
>mz
>
>–
>|| michael f. zbyszynski — molecular gastronimist
>|| http://www.cnmat.berkeley.edu/
>|| http://www.mikezed.com/
>
>
>


October 19, 2007 | 9:41 pm

Sorry, I posted the wrong build.

Should be fine now; same url.

mz

Quote: MJ wrote on Thu, 18 October 2007 17:06
—————————————————-
>
> it says :
>
> ZeroLink: could not load .o file:

> >
> >No guarantees:
> >
> >http://www.mikezed.com/p5osc.zip
> >
> >Put this in /usr/local/bin/
> >
> >
> >mz
> >
> >–
> >|| michael f. zbyszynski — molecular gastronimist
> >|| http://www.cnmat.berkeley.edu/
> >|| http://www.mikezed.com/
> >
> >
> >
>
>
>
—————————————————-


October 20, 2007 | 12:17 am

Change from "development" to "deployment" in XCode build settings.
Zerolink = BAD.

b

On Oct 18, 2007, at 5:06 PM, MJ wrote:

>
> it says :
>
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/macosx_usb_hid.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/main.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/IpEndpointName.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/NetworkingUtils.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/UdpSocket.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscOutboundPacketStream.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscPrintReceivedElements.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscReceivedElements.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscTypes.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscReceiveTest.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscSendTests.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/OscUnitTests.ob
> ZeroLink: could not load .o file: /Users/mzed/CNMAT/Code/trunk/
> devices/p5osc/build/p5osc.build/Development/p5osc.build/Objects-
> normal/i386/p5glove.ob
>
> -mj
>
>> Quote: david stevens wrote on Thu, 18 October 2007 15:49
>> —————————————————-
>> > Please let us know here if you do get it fixed – I’ve had no luck
>> > with my p5 (on my macbook pro) either.
>> >
>>
>> No guarantees:
>>
>> http://www.mikezed.com/p5osc.zip
>>
>> Put this in /usr/local/bin/
>>
>>
>> mz
>>
>> –
>> || michael f. zbyszynski — molecular gastronimist
>> || http://www.cnmat.berkeley.edu/
>> || http://www.mikezed.com/
>>
>>
>>
>

Barry Threw
Media Art and Technology

San Francisco, CA Work: 857-544-3967
Email: bthrew@gmail.com
IM: captogreadmore (AIM)
http:/www.barrythrew.com

Barry Threw
Media Art and Technology

San Francisco, CA Work: 857-544-3967
Email: bthrew@gmail.com
IM: captogreadmore (AIM)
http:/www.barrythrew.com

Barry Threw
Media Art and Technology

San Francisco, CA Work: 857-544-3967
Email: bthrew@gmail.com
IM: captogreadmore (AIM)
http:/www.barrythrew.com


October 20, 2007 | 9:16 pm

Quote: barry threw wrote on Fri, 19 October 2007 17:17
—————————————————-
> Change from "development" to "deployment" in XCode build settings.
> Zerolink = BAD.
>

Sorry; I was working too quickly. As I said in my last post,

http://www.mikezed.com/p5osc.zip

should work for everybody now.



MJ
October 22, 2007 | 10:07 pm

It works!

great!

thanks.

-mj

>Quote: barry threw wrote on Fri, 19 October 2007 17:17
>—————————————————-
>> Change from "development" to "deployment" in XCode build settings.
>> Zerolink = BAD.
>>
>
>Sorry; I was working too quickly. As I said in my last post,
>
>http://www.mikezed.com/p5osc.zip
>
>should work for everybody now.
>–
>|| michael f. zbyszynski — molecular gastronimist
>|| http://www.cnmat.berkeley.edu/
>|| http://www.mikezed.com/
>
>
>


June 3, 2011 | 10:49 am

Dear,
I’m also try to use the object P5 by CNMAT, but I don’t know the correct use: I must use Terminal before Max (as some older P5 in Max systems). Becouse the object can’t "connect to the glove".

I use a Mac Intel Core duo 2 on MacOS 10.6.7


Viewing 16 posts - 1 through 16 (of 16 total)