Forums > MaxMSP

pan mod

March 27, 2007 | 10:48 pm

Hi, can anyone help me? I’m trying to modulate the pan control on my patch using a matrix~ going into pan2 object. I figured I need to connect to the middle left inlet so it can go from left to right but this only accepts max numbers. Is it possile to convert a signal to a float or is there a simpler way to do this?
Thanks for any advice,
Steve H


March 27, 2007 | 11:08 pm

i don’t really understand what you want to do, but to convert from
signal to float, look at snapshot~ and maybe peakamp~.
but maybe it’s because i’m tired, but what do you exactly want and
why this way?

best

isj
On Mar 28, 2007, at 12:48 AM, Steven Holt wrote:

>
> Hi, can anyone help me? I’m trying to modulate the pan control on
> my patch using a matrix~ going into pan2 object. I figured I need
> to connect to the middle left inlet so it can go from left to right
> but this only accepts max numbers. Is it possile to convert a
> signal to a float or is there a simpler way to do this?
> Thanks for any advice,
> Steve H


March 27, 2007 | 11:16 pm

look at snapshot~, it will convert an audio rate signal
into a control signal.

—– Original Message —–
From: Steven Holt
Date: Tuesday, March 27, 2007 4:51 pm
Subject: [maxmsp] pan mod

>
> Hi, can anyone help me? I’m trying to modulate the pan control on
> my patch using a matrix~ going into pan2 object. I figured I need
> to connect to the middle left inlet so it can go from left to
> right but this only accepts max numbers. Is it possile to convert
> a signal to a float or is there a simpler way to do this?
> Thanks for any advice,
> Steve H
>


March 27, 2007 | 11:31 pm

sorry i’m also tired and not being clear. I am using matrix~ and matrixctrl to have a simple modulation matrix and so far managed to get the LFO to modulate the pitch of an oscillator but I can’t get it to modulate the pan and not sure what else I can modulate because I can’t connect the signal outputs of matrix~ to the float/int inlets.
Also I tried connecting to the filter cut off but it has no modulation effect. I think It’s because i need to scale the outputs of matrix~ but i can’t use scale for the signals.
Thanks,
Steve


Viewing 4 posts - 1 through 4 (of 4 total)