Forums > MaxMSP

Pan problem

March 31, 2011 | 2:46 pm

Hello,

I am having a little problem with my pan patch. It seams that when I pan all the way to the right I still have a bit of left signal. Can anyone help?

Thanks a lot

{
"boxes" : [ {
"box" : {
"maxclass" : "comment",
"text" : "Pan1",
"fontsize" : 9.0,
"textcolor" : [ 0.082353, 0.25098, 0.431373, 1.0 ],
"frgb" : [ 0.082353, 0.25098, 0.431373, 1.0 ],
"numinlets" : 1,
"numoutlets" : 0,
"id" : "obj-58",
"fontname" : "Arial",
"patching_rect" : [ 114.0, 121.0, 35.0, 17.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "receive~ P1",
"fontsize" : 12.0,
"numinlets" : 1,
"numoutlets" : 1,
"id" : "obj-221",
"fontname" : "Arial",
"outlettype" : [ "signal" ],
"patching_rect" : [ 43.0, 330.0, 74.0, 20.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "send~ PR1",
"fontsize" : 12.0,
"numinlets" : 1,
"numoutlets" : 0,
"id" : "obj-38",
"fontname" : "Arial",
"patching_rect" : [ 85.0, 482.0, 70.0, 20.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "send~ PL1",
"fontsize" : 12.0,
"numinlets" : 1,
"numoutlets" : 0,
"id" : "obj-37",
"fontname" : "Arial",
"patching_rect" : [ 43.0, 502.0, 68.0, 20.0 ]
}

}
, {
"box" : {
"maxclass" : "flonum",
"fontsize" : 9.0,
"bgcolor" : [ 0.866667, 0.866667, 0.866667, 1.0 ],
"htextcolor" : [ 0.870588, 0.870588, 0.870588, 1.0 ],
"numinlets" : 1,
"numoutlets" : 2,
"id" : "obj-26",
"fontname" : "Arial",
"outlettype" : [ "float", "bang" ],
"triscale" : 0.9,
"patching_rect" : [ 114.0, 175.0, 35.0, 17.0 ]
}

}
, {
"box" : {
"maxclass" : "dial",
"degrees" : 300,
"needlecolor" : [ 0.792157, 0.282353, 0.282353, 1.0 ],
"numinlets" : 1,
"numoutlets" : 1,
"id" : "obj-195",
"outlettype" : [ "float" ],
"size" : 129.0,
"patching_rect" : [ 114.0, 141.0, 32.0, 32.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "*~ 0.2",
"fontsize" : 11.595187,
"numinlets" : 2,
"numoutlets" : 1,
"id" : "obj-197",
"fontname" : "Arial",
"outlettype" : [ "signal" ],
"patching_rect" : [ 85.0, 420.0, 41.0, 20.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "*~ 0.2",
"fontsize" : 11.595187,
"numinlets" : 2,
"numoutlets" : 1,
"id" : "obj-198",
"fontname" : "Arial",
"outlettype" : [ "signal" ],
"patching_rect" : [ 43.0, 420.0, 41.0, 20.0 ]
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "pan2 100",
"fontsize" : 11.595187,
"numinlets" : 4,
"numoutlets" : 2,
"id" : "obj-199",
"fontname" : "Arial",
"outlettype" : [ "signal", "signal" ],
"patching_rect" : [ 43.0, 393.0, 61.0, 20.0 ]
}

}
],
"lines" : [ {
"patchline" : {
"source" : [ "obj-197", 0 ],
"destination" : [ "obj-38", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-198", 0 ],
"destination" : [ "obj-37", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-199", 1 ],
"destination" : [ "obj-197", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-199", 0 ],
"destination" : [ "obj-198", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-195", 0 ],
"destination" : [ "obj-199", 2 ],
"hidden" : 1,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-26", 0 ],
"destination" : [ "obj-198", 1 ],
"hidden" : 1,
"midpoints" : [ 123.5, 415.0, 74.5, 415.0 ]
}

}
, {
"patchline" : {
"source" : [ "obj-26", 0 ],
"destination" : [ "obj-197", 1 ],
"hidden" : 1,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-221", 0 ],
"destination" : [ "obj-199", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
]
}


March 31, 2011 | 4:52 pm

Panning to the right seems to fade out left o/p completely here.

To avoid the patch showing as in you post (which can get pretty long), when you copy patches to post to the forum, Use "Copy compressed" from the Edit menu.


March 31, 2011 | 5:42 pm

Thanks. Maybe is just a problem with my main patch. Will look at it better. Do you know how can I share a complete patch with all the subpatches?

Thanks again for the help


March 31, 2011 | 6:12 pm

AFAIK subpatches of the main patch are copied when Copy Compressed is used.

If you have seperately saved patches (abstractions) that need to be included as part of the main patch, you could either roll these in these as subpatches in your main patch before copying, or post each abstraction seperately ( via copy compressed) but that option means a bit more effort for the downloader to reassemble the patch as intended


March 31, 2011 | 6:19 pm

ok. Thanks a lot for the help. Will try to post what I am working on, to share it and get some imput on what to do better!


Viewing 5 posts - 1 through 5 (of 5 total)