panel and GUI objects issue

Jun 24, 2008 at 3:27pm

panel and GUI objects issue

is this a normal behavior ?
should a GUI object be still mouse sensitive when covered by a [panel] ?
i would expect GUI objects not to respond on mouse events when covered by any other object especially a [panel] .
thanks in advance for any info ;)

– Pasted Max Patch, click to expand. –
#38568
Jun 24, 2008 at 4:15pm

On 24 juin 08, at 17:27, karl-otto von oertzen wrote:

> is this a normal behavior ?

It’s the expected behavior, panel doesn’t grab the mouse events, so it
passes it to the next object behind. You might want to set the “ignore
click” attribute of your slider to 1, if you don’t want mouse
interaction.

Cheers,
ej

#134637
Jun 24, 2008 at 10:49pm

thanks for the clarification Emmanuel.
i was aware of the “ignoreclick” message, and was only wondering about panel’s relation to mouse events.
the ignoreclick message is great but in my case i need an easy solution to “show” that certain modules ( bpatchers) of a patch are inactive or disabled. therefore covering them with a translucid panel seemed a good idea ( like “greying” the module out ) instead of sending an”ignoreclick 1″ to numerous GUI elements.
ill just go with covering my modules with panels and ubuttons :)
thanks again for the great work on max5, it is making so many things so much easier :)

Quote: Emmanuel Jourdan wrote on Tue, 24 June 2008 18:15
—————————————————-
> On 24 juin 08, at 17:27, karl-otto von oertzen wrote:
>
> > is this a normal behavior ?
>
> It’s the expected behavior, panel doesn’t grab the mouse events, so it
> passes it to the next object behind. You might want to set the “ignore
> click” attribute of your slider to 1, if you don’t want mouse
> interaction.
>
> Cheers,
> ej
>
>
>
—————————————————-

#134638
Jun 24, 2008 at 11:35pm

#134639
Jun 25, 2008 at 6:42am

hum … i guess i forgot about this one :)

>
> also, maybe the clickthrough attribute of Bpatcher might help if you
> wanna superpose Bpatchers� maybe not ;-)
>
> ej
>
>
>
—————————————————-

#134640

You must be logged in to reply to this topic.