Patch cords ignore z-order in unlocked patcher

Apr 12, 2013 at 7:07pm

Patch cords ignore z-order in unlocked patcher

Have a look at the following. I can’t find any way to edit(i.e. drag) a patch cord segment if it over/underlies another object. All other objects seem to obey Send To Front/Back, but not patch cords. The odd thing is that it is selectable, but no grab handles. Why is that? Looks like a bug to me.

– Pasted Max Patch, click to expand. –
#66240
Apr 12, 2013 at 8:18pm

Hi ForestCat,

I can’t repro on Mac 10.7.5 or Win 7 x64 with Max 6.1.2. I wonder if there is some Max or System preference you have set that is preventing this from occurring. What OS are you running?

Patch cords should always be “on top” in an unlocked patcher.

-Ben

#238421
Apr 12, 2013 at 10:20pm

Ben,

Win7/32 , 6.1.1
When you paste that into your patcher, are you saying that you are able to drag the wire up and down vertically by clicking on it within the comment box? I can’t. As I said, if I drag the comment box away from the wire, I am then able to move it. Everything else works as expected, so I’m not sure what pref would specifically affect this functionality… The patchcords are “on top”, I just can’t move them when they wind up over another object.

#238422
Apr 12, 2013 at 11:01pm

Here is what I do:

1. paste patcher
2. click on patch cord to activate
3. click-drag patch cord up and down vertically

Not sure why there would be a difference here.

You could try trashing Max’s prefs to see if that helps. Quit Max, then go to /Users/yourname/AppData/Roaming/Cycling ’74/ and trash the ‘Max 6 Preferences Files’ folder

#238423
Apr 13, 2013 at 2:31am

I deleted the prefs, shut down everything, restarted, and now it seems to be working. Strange.

Thanks for your help, I wouldn’t have thought to try that.

#238424

You must be logged in to reply to this topic.