Forums > MaxMSP

Patch Crashing


dnz
September 23, 2011 | 7:48 am

hi sorry, i don’t understand why my post isn’t showing. I’m adding my crash log as a text now. hopefully it get’s displayed. patch inculded.

Problem,

i’ve made some changes to my patch and upon saving it crashes on me. After that the patch just keep crashing. Can anyone help or advice me on this? I’ve tried starting the patch holding command+shift but still no effect.

i’m on 10.6.8, max 5.1.5.

the patch can be open as text in max.

any advice? please help me on this, as i didn’t have any extra backup copy of this patch!

d

Attachments:
  1. ratgroove4A.maxpat

September 23, 2011 | 8:03 am

You may have a loadbang problem. You can disable loadbangs by pressing shift-cmd while opening the patch.



dnz
September 23, 2011 | 8:35 am

I’ve tried to disable the loadbangs as well. but still doesn’t work.


September 23, 2011 | 8:40 am

You have a stack overflow problem.
As it’s a relatively busy patch, it may take some time to track down the source, but I was at least able to open it.
If command-shift-opening it is still causing a stack overflow, then it can only be the autopattr – deleting it confirms this.
Open it as text, search out the autopattr and delete it – and then try and work out what it was initialising that was causing the stack overflow.
Good luck!
cheers
Roger



dnz
September 23, 2011 | 9:36 am

ah! yes it works now. autopattr is causing the crash!

thanks for help!

p.s. it would be great that maxmsp has a autosave function!


September 23, 2011 | 9:59 am

Yes, autosave would be nice, but as an alternative, you can always save your work to a Dropbox folder.
Dropbox keeps old versions that you can retrieve when it all goes a bit Pete Tong – got me out of trouble a few times!
cheers
Roger



dnz
September 23, 2011 | 11:19 am

ah!… that’s a good idea. i’ll check it out with dropbox!

thanks!


Viewing 7 posts - 1 through 7 (of 7 total)