Patcherargs doesn't work in a subpatcher?

Jul 15, 2008 at 3:43am

Patcherargs doesn't work in a subpatcher?

I was wondering if this is the expected behavior for patcherargs-

When patcherargs is in the top level patcher of an abstraction, it behaves normally. However, when it is embeded in a subpatcher the arguments given to the abstraction don’t carry through.

Here is an example:

save as argTest:

– Pasted Max Patch, click to expand. –

save as argTest2:

– Pasted Max Patch, click to expand. –

and then open this patcher:

– Pasted Max Patch, click to expand. –

Also attached is a zip of the above files, if you find that easier.

#38890
Jul 15, 2008 at 7:50am

Nick Inhofe schrieb:
> I was wondering if this is the expected behavior for patcherargs-
>
> When patcherargs is in the top level patcher of an abstraction, it
> behaves normally. However, when it is embeded in a subpatcher the
> arguments given to the abstraction don’t carry through.

It always had been like that, it was already discussed and unfortunately
won’t change. (though #x arguments are passed as we need them…)

If I do my scripting magic, I leave the patcherargs out of the
encapsulation. Works at least…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#136162
Jul 15, 2008 at 5:59pm

It’s not really a problem, I can just have patcherargs in the main patch. I wanted to point it out in case it was a Max5 bug.

#136163

You must be logged in to reply to this topic.