Patterstorage order of (recalling) operations?

Apr 2, 2013 at 6:53pm

Patterstorage order of (recalling) operations?

Is there a way to force a certain order of pattrstorage recalling values?

I’ve got some LFO/modifiers in my pattrstorage path and if I switch from a preset that has LFOs to one that doesn’t, it seems to muck up my recalled values. I get the feeling that it’s recalling the right values, then turning off the LFOs afterwards (with the LFOs controlling the values for a split second).

The modifiers are stored last on the .json file.

Here is one preset from my pattrstorage file (LFO/modifiers are at the bottom)

{
“pattrstorage” : {
“name” : “global_effects”,
“slots” : {
“7″ : {
“id” : 7,
“name” : “default settings”,
“data” : {
“fx_input::filter” : [ 0 ],
“fx_input::filterdirt” : [ 0.0 ],
“fx_input::filterfreq” : [ 0.9 ],
“fx_input::filterq” : [ 0.4 ],
“fx_input::filtershape” : [ 0.5 ],
“fx_input::filtertype” : [ 0 ],
“fx_input::lofi” : [ 0 ],
“fx_input::lofibit1″ : [ 1.0 ],
“fx_input::lofibit2″ : [ 0.95 ],
“fx_input::lofibitwise” : [ 1.0 ],
“fx_input::lofimp3ify” : [ 0.0 ],
“fx_input::lofisample” : [ 0.8 ],
“fx_input::pitch” : [ 0 ],
“fx_input::pitchblend” : [ 1.0 ],
“fx_input::pitchdirty” : [ 0 ],
“fx_input::pitchpreset” : [ 0 ],
“fx_input::pitchshift” : [ 0.0 ],
“fx_input::stutter” : [ 0 ],
“fx_input::stutterdd” : [ 0 ],
“fx_input::stutterdensity” : [ 1.0 ],
“fx_input::stutterkill” : [ 1 ],
“fx_input::stutteroverdub” : [ 0 ],
“fx_input::stutterrand” : [ 0 ],
“fx_input::stutterrate” : [ 0.8 ],
“fx_input::stutterrec” : [ 0 ],
“fx_output::chopper” : [ 0 ],
“fx_output::chopper_mode” : [ 4 ],
“fx_output::chopperblend” : [ 0.5 ],
“fx_output::chopperchop” : [ 0.1 ],
“fx_output::choppercross” : [ 0.0 ],
“fx_output::choppermax” : [ 1.0 ],
“fx_output::choppermin” : [ 0.0 ],
“fx_output::dirt” : [ 0 ],
“fx_output::dirtbass” : [ 1.0 ],
“fx_output::dirtc” : [ 0.08 ],
“fx_output::dirtg” : [ 0.5 ],
“fx_output::dirtmode” : [ 0 ],
“fx_output::dirtt” : [ 1.0 ],
“fx_output::reverb” : [ 0 ],
“fx_output::reverbblend” : [ 0.2 ],
“fx_output::reverbdamping” : [ 0.0 ],
“fx_output::reverbtype” : [ 0 ],
“fx_output::shuffler” : [ 0 ],
“fx_output::shufflerkill” : [ 1 ],
“fx_output::shufflerpercent” : [ 1.0 ],
“fx_output::shufflerpitch” : [ 0.2 ],
“fx_output::shufflerrand” : [ 0 ],
“fx_output::shufflerrate” : [ 0.2 ],
“fx_output::shufflershuffle” : [ 1 ],
“analysis::brain_chopper” : [ 1 ],
“analysis::brain_dirt” : [ 1 ],
“analysis::brain_filter” : [ 1 ],
“analysis::brain_lofi” : [ 1 ],
“analysis::brain_pitch” : [ 1 ],
“analysis::brain_reverb” : [ 1 ],
“analysis::brain_shuffler” : [ 1 ],
“analysis::brain_stutter” : [ 1 ],
“analysis::brainfx” : [ 1 ],
“analysis::brainfxmode” : [ 0 ],
“analysis::brainfxmorph” : [ 0.0 ],
“info::lfos1::1fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos1::1fx_modifiermapping[1]” : [ 0 ],
“info::lfos1::1fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos1::1fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos1::1fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos1::1fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos1::1fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos1::1fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos1::u905026463″ : [ ],
“info::lfos2::2fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos2::2fx_modifiermapping[1]” : [ 0 ],
“info::lfos2::2fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos2::2fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos2::2fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos2::2fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos2::2fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos2::2fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos2::u624026461″ : [ ],
“info::lfos3::3fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos3::3fx_modifiermapping[1]” : [ 0 ],
“info::lfos3::3fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos3::3fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos3::3fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos3::3fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos3::3fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos3::3fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos3::u885026459″ : [ ],
“info::lfos4::4fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos4::4fx_modifiermapping[1]” : [ 0 ],
“info::lfos4::4fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos4::4fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos4::4fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos4::4fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos4::4fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos4::4fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos4::u751026457″ : [ ],
“info::lfos5::5fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos5::5fx_modifiermapping[1]” : [ 0 ],
“info::lfos5::5fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos5::5fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos5::5fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos5::5fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos5::5fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos5::5fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos5::u386026455″ : [ ],
“info::lfos6::6fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos6::6fx_modifiermapping[1]” : [ 0 ],
“info::lfos6::6fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos6::6fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos6::6fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos6::6fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos6::6fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos6::6fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos6::u655026453″ : [ ],
“info::lfos7::7fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos7::7fx_modifiermapping[1]” : [ 0 ],
“info::lfos7::7fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos7::7fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos7::7fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos7::7fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos7::7fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos7::7fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos7::u753026451″ : [ ],
“info::lfos8::8fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos8::8fx_modifiermapping[1]” : [ 0 ],
“info::lfos8::8fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos8::8fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos8::8fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos8::8fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos8::8fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos8::8fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos8::u188026449″ : [ ],
“info::lfos9::9fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos9::9fx_modifiermapping[1]” : [ 0 ],
“info::lfos9::9fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos9::9fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos9::9fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos9::9fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos9::9fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos9::9fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos9::u793026447″ : [ ],
“info::lfos10::10fx_modifiersourceselect[1]” : [ 2 ],
“info::lfos10::10fx_modifiermapping[1]” : [ 0 ],
“info::lfos10::10fx_mod_bang_threshold[1]” : [ 0.0 ],
“info::lfos10::10fx_mod_lfo_speed[1]” : [ 0.0 ],
“info::lfos10::10fx_mod_highoutput_scaling[1]” : [ 1.0 ],
“info::lfos10::10fx_mod_lowoutput_scaling[1]” : [ 0.0 ],
“info::lfos10::10fx_mod_highinput_scaling[1]” : [ 1.0 ],
“info::lfos10::10fx_mod_lowinput_scaling[1]” : [ 0.0 ],
“info::lfos10::u320026444″ : [ ]
}

}

#67491
Apr 2, 2013 at 8:08pm

Perhaps I’m misunderstanding your question, but you can certainly double-click the pattrstorage object and set recall order (the priority column) manually. I think that if you’ve got a pattr object bound to some arbitrary UI object the pattr object’s parameter mode enable set, the pattr object’s default_priority attribute does the same thing. I could be wrong on that bit, though. I always set mine manually.

#242845
Apr 2, 2013 at 9:12pm

My bad, I didn’t realize there was a priority setting.

Even with that it was acting a fool, bit I figured out a workaround that’s working. (I’m banging a a 0. interpolation value after loading the preset, and that seems to do the trick…)

#242846

You must be logged in to reply to this topic.