Pattr w/ bpatcher

Aug 21, 2006 at 5:02pm

Pattr w/ bpatcher

Does anybody else have problems getting pattr to work with bpatcher? For some reason if I put pattr inside of a patch that i am going to use in bpatcher, pattr only remembers the settings as they are in the original patch and ignores any changes that I make while accessing it through bpatcher. If I try to put pattr in by using inlets and outlets then pattr just gets errors.

I’m still using 4.5 Is 4.6 stable?

#27233
Aug 21, 2006 at 5:16pm

If I correctly interpret your comments, you’re experiencing the
problem that after making changes to objects in a bpatcher, living in
a parent patch and saving that parent patch, the values as saved in
the original bpatcher file are restored the next time you load it?
This is unavoidable. What you need to do is use pattrstorage to save
a snapshot of the current values and recall it when you reload the
patch.

jb

Am 21.08.2006 um 19:02 schrieb Jhaysonn:

>
> Does anybody else have problems getting pattr to work with
> bpatcher? For some reason if I put pattr inside of a patch that i
> am going to use in bpatcher, pattr only remembers the settings as
> they are in the original patch and ignores any changes that I make
> while accessing it through bpatcher. If I try to put pattr in by
> using inlets and outlets then pattr just gets errors.
>
> I’m still using 4.5 Is 4.6 stable?

#82181
Aug 21, 2006 at 5:36pm

Thanks for the speedy reply.

I should’ve clarified a WHOLE lot better than I did. My apologies. You were right about what you said I am experiencing, however I am using pattrstorage to recall my data, I had just assumed that once I got this bpatcher idea to work, then I could worry about pattrstorage .xml files. My real problem is that even if I write an .xml file I still don’t retrive my settings when I go to ‘read’ that file. The thing that really confuses me is that I can actually see in teh clientwindow the changes..but only some of them. There are 4 bpatcher windows that I’m trying to work with and for some reason it only displays the name of the patch as the ORIGINAL -2 version prior to the one that I’m using – filename :P

#82182
Aug 21, 2006 at 6:06pm

Maybe you could send a link to a patch, or send it to me or
support@cycling74.com directly.

jb

Am 21.08.2006 um 19:36 schrieb Jhaysonn:

>
> Thanks for the speedy reply.
>
> I should’ve clarified a WHOLE lot better than I did. My
> apologies. You were right about what you said I am experiencing,
> however I am using pattrstorage to recall my data, I had just
> assumed that once I got this bpatcher idea to work, then I could
> worry about pattrstorage .xml files. My real problem is that even
> if I write an .xml file I still don’t retrive my settings when I go
> to ‘read’ that file. The thing that really confuses me is that I
> can actually see in teh clientwindow the changes..but only some of
> them. There are 4 bpatcher windows that I’m trying to work with
> and for some reason it only displays the name of the patch as the
> ORIGINAL -2 version prior to the one that I’m using – filename :P

#82183
Aug 22, 2006 at 2:22am

I used the forum to send you an e-mail that contains a link to a remote download. It’s small, and just an example, but still shows the problem I’m running into. I’m using some of my professors networking patches in my main patch and I don’t know how he would feel if I were to let someone see his work. Thanks again.

#82184
Aug 22, 2006 at 6:09am

I don’t appear to have received that. Could you resend using your
email client?

jb

Am 22.08.2006 um 04:22 schrieb Jhaysonn:

>
> I used the forum to send you an e-mail that contains a link to a
> remote download. It’s small, and just an example, but still shows
> the problem I’m running into. I’m using some of my professors
> networking patches in my main patch and I don’t know how he would
> feel if I were to let someone see his work. Thanks again.

#82185
Aug 22, 2006 at 2:12pm

Hm, well I couldn’t find your e-mail address on your forum profile, so I went ahead and just sent it to the cycling74 support address you listed with your name in the title. Thanks again.

J

#82186

You must be logged in to reply to this topic.