Forums > MaxMSP

Pattrstorage autosave still prompts to save

November 24, 2010 | 6:11 pm

This week after the upgrade to 5.1.6 pattrstorage began prompting me to save instead of autosaving
The savemodes seem to be working because savemode 0 does not prompt
savemode 2 prompts when I save the patch
and savemode 3 prompts when I close the patch

This is happening in both Max and Max for Live.

I haven’t seen any mention of this on the forums recently, so I think it could be specific to my computer .

How does pattrstorage accomplish an autosave (i can’t find .json files for any of the patches and sets which already have autosaved pattrstorage data)? What circumstances will cause pattrstorage to fail at autosaving and thus prompt the user to save a .json file?

The patch below is a simple example which produces the save prompt for me if I store some presets, save and close.

Thanks Cycling ’74 for making such an astounding creative tool! Happy birthday max for live!

– Pasted Max Patch, click to expand. –

November 24, 2010 | 8:07 pm

This patch works as expected. When you have savemode 3, you are telling the pattrstorage to autosave when the patcher is freed. If the pattrstorage object has never saved out a .json file before, there is no way to autosave, as it doesn’t know what file to use. So, it prompts you to save.

What is meant by ‘autosave’ is if you have previously written out a preset file, it will autosave the current storage slots of the pattrstorage, as long as Max can still find that file.

One neat thing about pattrstorage is if you choose ‘parameter_enable’ in it’s inspector, it will automatically save the storage slots with the patcher.

Let me know if I’m misunderstanding your problem.

-Ben


November 24, 2010 | 9:42 pm

My concern is saving the pattr data of a M4L device with the live set. I would like my devices to simply recall the presets I have made for that set without ever initially saving a preset file. Is the attached max audio device set up correctly for this?

Originally, i had my pattrstorage set to parametermode enable, autorestore 1, savemode 1. and It was successfully recalling whatever whenever I opened a set, but at the moment, devices which haven’t been edited are now prompting me to save when they didn’t before.

If I enable parameter mode in a maxpatch (not a live device), will i be able to open the patch with pattrstorage data recalled automatically?

In the patch I pasted in my earlier post, I have enabled parametermode, and autorestore
made some presets,
saved the patch
close the patch
Went ahead and saved a .xml with the same name as the patch.
reopen the patch
the pattr object is recalling the previous state of its bound numberbox, but pattrstorage is empty

thanks for your help, I’m really confused here

Attachments:
  1. pattrsavetest.amxd

November 24, 2010 | 10:08 pm

Hi Morgan,

In this device, the parameter_enable was not set to 1.

Regardless, to do what you want to do, set the parameter mode enable to 1, the initial enable to 1, and the Auto-update Parameter Initial Enable to 1.

You will also want to set the savemode to 0 and the autorestore to 0, as it doesn’t sound like you want a preset file at all, and rather want the pattrstorage’s parameter to save the slots.

A lot of hoops, but very useful!

-Ben


November 25, 2010 | 2:29 am

Thanks Ben! ‘*v’* That does the trick.


Viewing 5 posts - 1 through 5 (of 5 total)