Pattrstorage -> changing between Presets often DAC switching off

Jun 20, 2013 at 12:35pm

Pattrstorage -> changing between Presets often DAC switching off

Hello!

I am wondering about a problem:
I am using max for live-electronic. In my patch I am changing presets
using pattrstorage and autopattr. Now, when i do so, the dac often switches
off – just for a split of a second – but enough. I checked (hopefully) all connections to the autopattr and pattrstorage object – without any success.
no dac~ or ezdac~ is listed in the storage/clientwindow…
maybe someone can help me??

Thank you very much!!

best tim

#253462
Jun 20, 2013 at 12:55pm

Max does sometimes suspend operations during pattrstorage recalls.
Also, if you have a named umenu attached to [ad_status switch] it may be included in the pattr system.
Is the dac actually switching off, or is sound just interrupted? Maybe you can test by attaching [ad_status switch] to a print object. Switch between some prestes and note the behavior in the Max window.

#253476
Jun 20, 2013 at 1:40pm

Hey,

thank you for your really quick reply!
i was adding an [ad_status switch] and printing out during switching between presets. it is always set to “set 1″, so it’s only interrupting the audio/sound. New Patchers with en ezdac~ are also not affected.
and the problem is not existing in every preset. sometimes it works without interrupting.
so audio sometimes is interrupted exactly during the process of recalling some other presets…

#253477

You must be logged in to reply to this topic.