Forums > MaxMSP

pattrstorage refuses different interp-modes

October 12, 2013 | 1:06 pm

In my patch I perfectly can morph pattrstorage between different stores, but why the interp message has no effect, whatever I try?

Thanks for all help
Peter

– Pasted Max Patch, click to expand. –

October 12, 2013 | 2:22 pm

you forgot the scripting name of your slider:

<code>

– Pasted Max Patch, click to expand. –

</code>


October 14, 2013 | 7:59 am

Thanks. That really helps.
But it also raises the next question:
What if I want to change the interp-mode for a lot of sliders? Do I have to name them all in their own interp message?

Thanks a lot again.
Peter


October 14, 2013 | 1:57 pm

yes, but you can use uzi with combine, prepend etc to construct sequenced messages, or have your commands in a coll, again access them with uzi, or dump. naming your sliders sequentially, ie name[1], name[2] etc also helps


October 14, 2013 | 2:56 pm

or you can just double-click pattrstorage and change all the ones you want set to something other than linear. It only takes a few seconds, typically.

Normally you wouldn’t dynamically switch interp modes, I think. But then again, this is max, we come here for the complicated stuff, right? X)


October 15, 2013 | 3:26 am

Thanks to you.
And indeed, normally you wouldn’t change interp on the fly. But yes, I want to do that, so my moving lights can have nicer curves for different moves. And intensity curves of lights can be adapted to the kind of light. And indeed. That is why this is MAX. And that is why I like it.
And yes, in the mean time I programmed a workaround to automize this interp settings using a message-list containing the different aliases and iter to trigger them into a sprint.

But again, thanks for all your help.

Peter


October 15, 2013 | 9:40 am

So you’re changing it for *all* the lights each time, or is it just for some?


Viewing 7 posts - 1 through 7 (of 7 total)