perticualr patch keeps crashing when i turn audio on.

Jun 18, 2009 at 11:22pm

perticualr patch keeps crashing when i turn audio on.

i have this granular patch witch plays back samples. when i tried to work on it tonight it kept crashing when i turned audio on.
i have tried everything i know. maybe it’s a bug in 5.0.7?

patch:

– Pasted Max Patch, click to expand. –

console message:

19-06-09 00:57:27 macbook-pro com.apple.launchd[71] com.apple.launchd 71 com.apple.console Warning ([0x0-0x32032].com.cycling74.MaxMSP[335]) Exited abnormally: Bus error
19-06-09 00:57:46 macbook-pro [0x0-0x37037].com.cycling74.MaxMSP[349] [0x0-0x37037].com.cycling74.MaxMSP 349 com.apple.console Notice sqlite version 3.6.11
19-06-09 00:57:46 macbook-pro [0x0-0x37037].com.cycling74.MaxMSP[349] [0x0-0x37037].com.cycling74.MaxMSP 349 com.apple.console Notice sqlite version 3.6.11
19-06-09 00:57:47 macbook-pro- [0x0-0x37037].com.cycling74.MaxMSP[349] [0x0-0x37037].com.cycling74.MaxMSP 349 com.apple.console Notice Max: starting db update
19-06-09 00:57:53 macbook-pro [0x0-0x37037].com.cycling74.MaxMSP[349] [0x0-0x37037].com.cycling74.MaxMSP 349 com.apple.console Notice Max: db update complete
19-06-09 00:57:53 macbook-pro- [0x0-0x37037].com.cycling74.MaxMSP[349] [0x0-0x37037].com.cycling74.MaxMSP 349 com.apple.console Notice Max: db update complete
19-06-09 00:58:20 macbook-pro ReportCrash[355] ReportCrash 355 Crash Reporter Notice Formulating crash report for process MaxMSP[349]
19-06-09 00:58:21 macbook-pro com.apple.launchd[71] com.apple.launchd 71 com.apple.console Warning ([0x0-0x37037].com.cycling74.MaxMSP[349]) Exited abnormally: Segmentation fault
19-06-09 00:58:21 macbook-pro ReportCrash[355] ReportCrash 355 Crash Reporter Error Saved crashreport to /Users/Younes/Library/Logs/CrashReporter/MaxMSP_2009-06-19-005818_macbook-pro.crash using uid: 501 gid: 20, euid: 501 egid: 20
19-06-09 00:58:21 macbook-pro ReportCrash[355] ReportCrash 355 Crash Reporter Error Saved crashreport to /Users/Younes/Library/Logs/CrashReporter/MaxMSP_2009-06-19-005818_macbook-pro.crash using uid: 501 gid: 20, euid: 501 egid: 20

#44444
Jun 18, 2009 at 11:26pm

i’m on osx 10.5.7 by the way.

#159836
Jun 18, 2009 at 11:34pm

not that this is a solution

but try creating a patch which turns your dac on and then try opening your patch after this

#159837
Jun 18, 2009 at 11:34pm

You haven’t included your “gran-poly” [poly~] subpatch which might help find the problem.

lh

#159838
Jun 18, 2009 at 11:55pm

sorry:

– Pasted Max Patch, click to expand. –
#159839
Jun 19, 2009 at 12:04am

No crash here, although I’m still using 5.0.4. Try trashing all your max prefs and resetting the database then loading it again. Otherwise I’m not sure what the problem is. You might want to chop bits out of your patch until you find out if a certain bit is causing the crash then email support about it.

lh

#159840

You must be logged in to reply to this topic.