Phasor lock distortion

Jun 25, 2008 at 7:52pm

Phasor lock distortion

I’ve been trying to use a transport-locked phasor~ to playback some loops via wave~. Unfortunately, I’ve noticed that when phasor’s lock mode is set to 1, it creates a lot of aliasing/distortion on the wave~ playback.

I’ve tried using play~ as well (with a little math) and got the same result.

I realize that this may be due to how phasor~ syncs itself with the transport, but I’m hoping there is some way around it.

Here is an example patch, you’ll have to supply your own 1 bar loop though.

– Pasted Max Patch, click to expand. –
#38597
Jun 25, 2008 at 8:22pm

I’m not hearing it. But since I have no idea what machine, OS, etc. you’re running on (I’m doing the current beta, MacBook Pro, 10.5.3, in the interests of reciprocity), I’d be guessing. Your airport is off, right?

#134739
Jun 25, 2008 at 8:28pm

I didn’t realize it, but overdrive and audio interrupt were off. I turned them on and it fixed the problem. Strange!

#134740
Jun 25, 2008 at 8:34pm

On 25 juin 08, at 22:28, Nick Inhofe wrote:

> I didn’t realize it, but overdrive and audio interrupt were off. I
> turned them on and it fixed the problem. Strange!

Overdrive and scheduler in audio interrupt must definitely be both on
in order to make sure of a tight synchronisation.

ej

#134741
Jun 25, 2008 at 8:39pm

Ah – there it is. Something like this would have
been a good deal more helpful (since you can
pretty clearly a/b it to verify).

– Pasted Max Patch, click to expand. –
#134742
Jun 25, 2008 at 8:45pm

Sounds here like they’re *both* doing *some* aliasing,
which I might expect. But the idea is that the locked
phasor~ is considerably more intolerable on your system?
It’s there, but not quite so screamingly. Perhaps what
I’ve got in this folder has too much high-end in it (or
perhaps I like aliasing….).

It might also help to ask about what kinds of loops
you’re running through this (external soundcard?], etc.
too.

#134743
Jun 25, 2008 at 9:14pm

You can still use timevalue syntax if the phasor is not locked. My example was fine. The overdrive/AI made the difference.

Its funny though, since phasor~ is signal rate anyway. I’m sure its some backend stuff I don’t understand.

#134744
Jun 25, 2008 at 9:24pm

phasor~ locking requires precise and regular updating of the current time, which is only provided by overdrive and SIAI. There will still be some aliasing with any tempo-locked phasor however.

If you don’t lock the phasor~, you can use any configuration you want. You might be able to get away with “cheap” locking by resetting the phase to 0 when the clock starts. Then you have two free-running clocks that started in the same place…but it might work for a while.

David Z.

#134745
Jun 25, 2008 at 10:09pm

Thanks for the info! For what I’m doing, the locked phasor in overdrive is fine. I’m not even sure why overdrive was turned off in the first place!

#134746

You must be logged in to reply to this topic.