Forums > MaxMSP

Pitch~ broken in max (also broken in help files)

November 8, 2013 | 4:10 pm

I’m trying to the use the pitch~ object in max but it seems completely broken. When I create a new instance of the object in an empty patcher or even just open the help file the pitch component has the horrible red tinge to it saying it isn’t working. Images attached.

Is there a reason why this might be happening? Is there anything I can do to fix it?

Attachments:
  1. Screen-Shot-2013-11-08-at-23.49.16
  2. Screen-Shot-2013-11-08-at-23.49.05

November 8, 2013 | 4:28 pm

I don’t think that’s been converted to 64-bit yet. Either you have to run in 32-bit mode, or use analyzer~.

Or, use fzero~.


November 8, 2013 | 4:35 pm

How do I run max in 32-bit mode?


November 8, 2013 | 4:40 pm

And what’s analyzer~? It doesn’t come up when I try to create it as an object in max.

Thank you by the way. I really appreciated the advice.


November 8, 2013 | 8:30 pm

What OS are you running? You can find the latest version of pitch~, and analyzer~, here:

http://cnmat.berkeley.edu/downloads


November 9, 2013 | 4:45 pm

Oh great. Thanks. I downloaded the file and I can see the pitch.maxhelp and even analyzer~ but they still don’t actually seem to be working with my copy of max. If I double click them they are still in red. I even set the folder in my file preferences but it’s not working. Sorry for not knowing too much about this stuff. I usually just type in the name of the object and at least isn’t redded out.

Reinstalling max now to see if that can fix it. Will report back.


November 9, 2013 | 4:59 pm

Update: Downloaded Max 6.1, analyzer~ and pitch~ still broken :(


November 9, 2013 | 5:01 pm

Oh sorry. Also, I’m running macintosh. 10.7.5


November 9, 2013 | 5:16 pm

I also found this which is interesting. Had an error saying I had multiple copies of pitch~ etc. So deleted all my file preferences. Then tried with pitch~ again. Didn’t work (obviously) tried to access the help file. Wouldn’t work. Added back in those CNMAT files that were linked above, the help file works, BUT, when I actually try to get use pitch~ I get the error message ‘no such object exists’ picture related. I notice in those CNMAT things there isn’t actually a copy of the pitch file, just the help file.

But I have exactly the same problem with analyzer~ and that doesn’t produce any error messages…

Attachments:
  1. Screen-Shot-2013-11-10-at-01.00.42

November 9, 2013 | 5:55 pm

No object from that CNMAT externals folder is working. Could it be that files inside are of the wrong type. I tried change analyzer~ to a .mxo but it didn’t help.

Attachments:
  1. Screen-Shot-2013-11-10-at-01.46.01

November 11, 2013 | 8:37 am

How do I run max in 32-bit mode?

Same way you run any application in 32-bit mode: select the application in the Finder, Get Info, check the "Open in 32-bit mode" check box.


Viewing 11 posts - 1 through 11 (of 11 total)