Forums > MaxMSP

pitch~ data trouble

August 17, 2010 | 7:38 pm

Hi,

I have been working with pitch~ patch based on the fiddle~ patch. I do however have a major problem. The input frequency is from a guitar through an mbox2. Although it is reading the frequency from the guitar, individual frequencies cannot be triggered. Any frequency triggers a bang, even though a pitch system using ,= symbols and the select function has been set up correctly. I am lost please help.

Regards,
R

– Pasted Max Patch, click to expand. –

August 17, 2010 | 8:02 pm

The message boxes in your subpatcher do not pass the output through of >= and < = - every time they receive a value they output 1 and so the addition is always equal to two and you always get a bang.

There’s a corrected version of just that bit below:

Below that is a much easier way to do this:

Alex

----------begin_max5_patcher----------
549.3ocyV9saaBCEF+Z3ovx2NVD1XZRp5lz50qOASUS7G2VOA1Hvnl0p9tOi
MjjFQTraHrdCHrOX+c9c9NFd02ClJ1PaffqA+B348pummdntA75e1CVlrIqH
oQGFLsUJEbXfYJdaIiWPk54P8Cxx0QJR+yWiP6EonUdXnUIxrmX7G+cMMSZj
AJZ0hv..lfz2BGtBtu+cLKi7uUTyK.SS3OBA22M6a99cWBtHICl3bxbkQ9QK
u74Bm9rRjCJTR2nk.76eCrBOL5CBtrg8hdyPXkZFIwwij3Q6u.7jR8B.+QMK
ovcjnqqnU5p7th7wQBiKmThbihHjyjHnqlPhfPDCRVdwQhiF9nX2SlPs9ihi
+uY4anEJ4.F20G5fq2YaO93bYsAKX8MRrofeRrD.fePzzVlRqGTYUsPJ5V6s
IwcjetXPktvoQcI3iyIvshhb2gktg.2eFQ3ogUWCQvVqzfgnl0jkTniIbwx3
oyg8ky1ZglvyOVi0zJlXbXKhsgVeHW0CEBkpb4ryw9mfIrqhD0kyF6RrEm0n
Rfj8cJSmknFTwTxyE1DNx2UlPaAw3GVq6ghNMadONzwAKX7C+8P8N0M96YTi
nsNaXoF9DIX21kSajLdhjo97ytfzMB.z1ndhkmS46CmRVdkPYX6UwQJY1Jpt
+jwRQE9ISTjYUSVU8lYNYWs6SmjN.kWd2DxJNgmYUgsRUQyrprySEOu8d1z5
cFJR8va9+C.SFipD
-----------end_max5_patcher-----------
----------begin_max5_patcher----------
318.3ocmSEraCBCC8b3qHJmYUDnEU1s8cLUMEfrVOAIHvnwVU+2GI.BZGUzx
EGkmcd1OamyNDVrtQVwnuRemRHmcHDKjAfzemvxEMIYhJaXLk7ac7WL2NWnr
AsvkzB.SNMf+oVgUvuRiOt+FudXUcNnxjnkpAPH0xPKquDDMk.kH2R.6sRPj
wF4PWiCjv6QKDsYGTG+nTlfc5wmG1lXZTjwtMvX8813QOz+jNVveJjcwyXzC
FOWbbLF2GrgDWinVwlSg7YTn+Z0AOzaPBKIjXg535DycltUEY.R26S2u8Ylv
A+W+7cO6D1e4NSfI+zvcK2Y.Exb6Ntp+XeAKCT29YvlUC90MsJccYx.oCatz
wDmJqPPIPncyXLHi3mDzIHMUpl9UHGRKzsEWeQbmQ3iVS2jt4qIyB4pqo1KW
b9yBQu+M
-----------end_max5_patcher-----------

August 28, 2010 | 7:55 pm

Thanks man split works a treat, Im now having trouble connecting two wii remotes to my computer it finds one and connects with max ok but the other one wont stay connected any clues?

Thanks
Rick


Viewing 3 posts - 1 through 3 (of 3 total)