Pixelation in jitter

Jan 25, 2007 at 10:58am

Pixelation in jitter

Hi,
I used jitter for the first time with a projector the other day and to my suprise all my video was awfully pixelated. I tried upping the resolution in jit.qt.movie using only raw dv footage but the result was largely the same.

I used a jit.qt.movie object then attached it to a floating jitter window and the made it fullscreen. Is there a better more efficient way of acheiving fullscreen displays in jitter with little or no pixelation?

cheers,
adam

#29932
Jan 25, 2007 at 12:17pm

without knowing anything more of your patch (or your level of
experience with jitter) i’d suggest checking whether the dimensions
of all your jitter objects are correct..

ciao,

Joost.

On Jan 25, 2007, at 11:58 , adam synnott wrote:

>
> Hi,
> I used jitter for the first time with a projector the other day and
> to my suprise all my video was awfully pixelated. I tried upping
> the resolution in jit.qt.movie using only raw dv footage but the
> result was largely the same.
>
> I used a jit.qt.movie object then attached it to a floating jitter
> window and the made it fullscreen. Is there a better more efficient
> way of acheiving fullscreen displays in jitter with little or no
> pixelation?
>
> cheers,
> adam

——————————————-

Joost Rekveld
———– http://www.lumen.nu/rekveld

——————————————-

“Politicians should read science fiction,
not westerns and detective stories.”
(Arthur C. Clarke)

——————————————-

#94502
Jan 25, 2007 at 5:20pm

On Jan 25, 2007, at 2:58 AM, adam synnott wrote:

> I used jitter for the first time with a projector the other day and
> to my suprise all my video was awfully pixelated. I tried upping
> the resolution in jit.qt.movie using only raw dv footage but the
> result was largely the same.

Needs to set the highquality flag for DV footage (either in
QTPlayerPro and save the file, or in Jitter). In the forthcoming
1.6.3, this is now on by default.

> I used a jit.qt.movie object then attached it to a floating jitter
> window and the made it fullscreen. Is there a better more efficient
> way of acheiving fullscreen displays in jitter with little or no
> pixelation?

@interp 1 to jit.window

-Joshua

#94503
Jan 26, 2007 at 8:19am

cheers

#94504
Jan 26, 2007 at 12:02pm

is there a more efficient interp object who can makes a blurry effect?

#94505
Jan 26, 2007 at 4:44pm

This came up on the list recently — search for recent posts by Joshua Kit Clayton in which he described how to do this with a shader. I’d send a link but I’m mobile at the moment.

best,
dan

#94506
Jan 29, 2007 at 2:53pm

thanks. I try to use the fire effect with jit.qt.effect but there is a lot of pixelation even if i use interp.

#94507
Jan 29, 2007 at 3:19pm

The object appears to be doing the right thing – the effect is
generated to match the size of the matrix coming in. So, sending a
[ jit.matrix 4 char 640 480 ] to jit.qt.effect yields a 640×480 fire-
effected matrix, as expected. That QuickTime’s fire effect is not
particularly beautiful is another story, but it’s not exhibiting any
unexpected pixelization.

jb

Am 29.01.2007 um 15:53 schrieb tenshi:

> thanks. I try to use the fire effect with jit.qt.effect but there
> is a lot of pixelation even if i use interp.

#94508
Jan 30, 2007 at 10:13am

thanks i’ll try to do that. I also heard about the jit.fastblur who can remove the pixelation.

#94509
Mar 11, 2007 at 11:52pm

Hi,

I just had a similar issue: I had a [jit.window] attached to [jit.qt.movie] reading a quicktime file that was using dv codec. The quicktime was very pixelated especially when fullscreen.

I just re-exported my footage using Photo-JPEG codec via Quicktiime Pro 7.1.3 and added a @interp 1 message to [jit.window]. The pixelation seems to have greatly improved on my computer screen. I have yet to test it on a projector or larger monitor.

Best,

Niknaz

#94510

You must be logged in to reply to this topic.