Forums > MaxMSP

play~ & poly~ (poly silent on first round of targets)


kp*
November 24, 2009 | 7:59 pm

I am not sure what is happening here. I have play~ inside a poly~ and it *almost* works correctly.

1. I set the playback speed.
2. I set the buffer and bang info~ for the duration
3. set the line for playback (forwards or back wards)
4. pack than in a line
5. set target number with counter

and send that all into the poly via (target $1, $2, $3, $4)

should work right?

I have the counter and poly set to 4 (so i can debug quicker will increase later).

but the first four events are silent.
Then it works fine.

If i set the counter to 16 and the poly to 16. Then the first 16 instances are
silent and then it works fine.

I tried using thispoly~ in the poly, i tried it without.
i tried prepend note & i tried using mute 0, 1 & mute 1, 0
i tried setting target manually
i tried putting thispoly~ on a sig

First round of events are silence. Then it works as expected.

Any help would be greatly appreciated. I been banging my head against this all week and have tried everything i can think of. I am desperate to get this going so i can get on to the next thing, but i just do not see what is wrong with this patch.

– Pasted Max Patch, click to expand. –

November 25, 2009 | 1:43 pm

Sounds like there might be an "order" problem. Are the bangs/messages sent in the correct order?



kp*
November 26, 2009 | 5:51 pm

You are right. It was an order problem. I’ve since fixed it and few other things and it now works like a charm (though play could sound nicer ~_- ). It was something that was encapsulated and hence out of sight. I should have gotten the order sorted out and then did the clean up.

cheers,


Viewing 3 posts - 1 through 3 (of 3 total)