Forums > MaxMSP

play samples at the same time

May 13, 2014 | 12:35 pm

hi,

i use sfplay to play samples. When it get’s triggered before a sound is done then it restarts playing without finishing the first one. How can i make it so that it can play multiple samples at once?

Doeke


May 13, 2014 | 1:28 pm

you’ll need multiple sfplay~ objects. (you may also want to look at poly~ for dynamically allocating voices/copies of your sfplay~ patch…)


May 13, 2014 | 2:33 pm

can you help with one more?

I want to keep some sound samples in the project folder i created. But if i use a message with "preload 10 Clap-LD.aiff" then cue 10 is still empty.
How can i make it look in a project folder?


May 14, 2014 | 2:55 pm

hmmm… i haven’t bothered to learn much about the new max6 ‘projects’ feature. if by ‘project folder’ you mean that kind, i’m not sure…
but if by ‘project folder’ you just mean a regular folder where your max patch is saved, then keeping sound files in that same folder where the max patch that addresses them should work… (i just tried and that seems to be working for me)…

wait… i just tried using the max6 ‘projects’ feature… it works similarly, lemme see if i can describe what i did:

1)had my original sfplay~ testing patch open
2)from the max ‘file’ menu, i did ‘save as project…’
3)in the save dialog, made sure to save the project somewhere i’d find it easily(desktop)
4)move an .aif file into the project folder
and then it worked fine.

but oh snapz! i also quit out and then when i reopened the project file, max saw the .aifs, created a new ‘media’ folder, and then placed the soundfiles in there automatically(i guess that makes it even easier for max6 projects to find them…)… it rearranged the file-structure on my computer without even asking my permission?! That. Is. HIGH. TECH. :D

so anyways, whether just using a regular folder or a project folder, a max patch should find any soundfiles stored in its same folder.
if you’re using a max6 project folder, try creating a ‘media’ folder and then putting the files in there…
otherwise, it should work(if not, you could also either put the folder into max file prefs… or just use an absolute file path like so:
[preload 10 "HD/Users/myusername/desktop/myfolder/Clap-LD.aiff"]….<-you don’t even need the quotes there, but they’re good for when you need to keep filenames with spaces in tact…)….

if you’re still having trouble, maybe give any other details you have(anything else you’ve tried, etc.), bump this thread, someone else might have better answers.
Hope it helps.


Viewing 4 posts - 1 through 4 (of 4 total)