playing simple multichannel files (11) problem

Feb 10, 2014 at 7:02am

playing simple multichannel files (11) problem

Hi there i have a strange problem, i have some 11.1 files that i’d like to play. Sfplay~ stops them right after 1 second. When i use 9.1 it woks. So it seems like a channel limitation.
While Groove and play cannot reach more than 4 channels apparently.
Have you had the same?
Any way to solve this?
cheers

#280594
Feb 13, 2014 at 12:05am

You have to find the right buffer size for sfplay~. Check the buffer_size panel in the help file.
Try with BIG sizes. Note that this is related to the speed of your hard drive, laptop internal drives are (were?) often slower than others…

#280933
Feb 13, 2014 at 12:31am

Thanks Patrick, i’ll check that. But it’s strange it’s just some 5 second files. And also i noticed that groove~ and play~ cannot play 11 channels… kind of surprising..
A

#280935
Feb 13, 2014 at 1:04am

buffers are limited to 4 channels. But you could use 3 of them and play them in sync.

#280943
Feb 13, 2014 at 2:38am

yep this is what i’m doing …. thanks

#280954
Feb 13, 2014 at 7:16am

As Patrick says, you should try setting larger buffer sizes for `sfplay~` (and sflist~ also I think if you are using it). According to the part of the help file mentioned above, I think you are supposed to manually set the buffer size if you are using more than 8 channels.

Hard drive speed is something that could come into play. IF you are on a Mac, try XBench to do a performance test on your HD so you know what kind of throughput is available to you.

Also, something else to watch out for with hard disk playback or recording is having your drive spin down because the computer put it to sleep. Again, on a Mac you can adjust this in System Preferences > Energy Saver (not sure how on Windows—anyone else?).

#280978
Feb 13, 2014 at 7:30am

ok now everything is clearer, at the beginning i did not get that the buffer size is an argument (never encountered it before in sfplay) and i was wondering you talked about the buffer~ in groove~. Now i got it. Thanks a lot.
A

#280984
Feb 14, 2014 at 6:44am

Hi everyone I’m working with the writer of the post and I tried to increase the size of the buffer-size but it didn’t change anything the audio is still kind of looping at the first second.

Because I’m using a 10.1 setup I’ve 11 channels and here is what I put in the splay object box : sfplay~ 11 @buffer-size227160

Can someone help ?

thanks

#281091
Feb 16, 2014 at 6:39pm
– Pasted Max Patch, click to expand. –
#281315
Feb 17, 2014 at 6:28am

Thanks you very much keep sound, it works great now !

Have a good day

#281373

You must be logged in to reply to this topic.