Playstation 3 controller

Mar 18, 2007 at 9:27am

Playstation 3 controller

I am trying to connect my Playstation 3 USB controller using the ‘Hi’ object. I am running Windows XP.

I opened the hi.help file and the playstation controller shows up in the umenu, however the controller doesn’t output any data.

I think problem lies in the fact that when the controller is connected via the usb cable, it first waits for a response from the playstation 3 unit before turning itself on.

How would I send an ‘assign controller to #1′ message from Max to the controller? Is it even possible to send data out from the ‘hi’ object?

Any insight into this matter would be appreciacted. Thanks.

#30893
Mar 18, 2007 at 6:07pm

Hi Thomas,
Sounds like you would benefit from reading the new Tutorial on the
Cycling ’74 website called “Making Connections: Connecting a Joystick to
MaxMSP/Jitter”:

http://cycling74.com/story/2007/3/12/113645/135

Cheers,
Andrew B.

#99439
May 10, 2007 at 10:34am

hello i had the same problem with the ps2 controller, but it looks
like a sort of initialisation stuff
try this:

1) connect the ps3 -> usb converter
2) start up max and the patch
3) connect the ps3 controller
4) send a menu message to hi

if it doesn’t work try to unconnect and connect again the ps3
controller leaving the patch open

this is not very technical but maybe it can works….

all the best
e.

Il giorno 18/mar/07, alle ore 10:27, Thomas DeFelice ha scritto:

>
> I am trying to connect my Playstation 3 USB controller using the
> ‘Hi’ object. I am running Windows XP.
>
> I opened the hi.help file and the playstation controller shows up
> in the umenu, however the controller doesn’t output any data.
>
> I think problem lies in the fact that when the controller is
> connected via the usb cable, it first waits for a response from the
> playstation 3 unit before turning itself on.
>
> How would I send an ‘assign controller to #1′ message from Max to
> the controller? Is it even possible to send data out from the ‘hi’
> object?
>
> Any insight into this matter would be appreciacted. Thanks.
>
>

#99440
May 10, 2007 at 3:42pm

are you remebering to poll the hi object?

#99441
May 11, 2007 at 8:32am

hey thomas,
do it works now?have you value now?
i m interesting on it..

thanks

freeka

#99442
May 14, 2007 at 6:06pm

Hi there,

I have the same problem with SIXAXIS ps3 controller.
While I poll it it comes out in umenu but no values there …
Have anyone make it work??

greets

R

#99443
May 14, 2007 at 6:10pm

forget it!

it was stupid..
the problem is only a driver problem…
computer can see the ps3 controller but the sixaxis need a command from the laptop to active the value…

so nothing possible until a driver come..

sorry

freeka

#99444
May 14, 2007 at 6:40pm

You are right Freeka the thing is I installed the driver on my PC and hi shows 0 elements
While on MAC where is no drivers so far?
it come out 35 elements under the PLAYSTATION(R) Controller..
strange isn’t it?

we will have to wait for a driver or max object :]

greets

R

#99445
May 14, 2007 at 8:32pm

I just got the values from it. You just have to install the driver
windows only :(

http://zedomax.com/blog/2006/12/09/ps3-hack-ps3-six-axis-controller-can-be-used-in-windows/

and no BT so far.

greets

R

#99446

You must be logged in to reply to this topic.