Forums > Max For Live

please test this patch…

October 4, 2010 | 6:10 am

i want to learn if you have the same problem with me..

this patcher if you have a looper(the ableton device) as a first device in the second track, normally controls the stop,rec,play buttons.

in my laptop controls the clear button..

i know that this is wrong because i have tested this patch in version 8.1.4
and it worked fine…the problem appears in versions 8.1.5, 8.2
(i have also check various versions of max but the problem resists)

and also i have test all the other parameters
(path live_set tracks 1 devices 0 parameters 2 etc)
and there is no possibility to control rec,play,stop button..

thanks — George..

Attachments:
  1. test_looper.rar

October 5, 2010 | 3:29 am

Not sure I understand here… "The looper as the first device on the 2nd track"; you mean as the first device on a midi track ?

Can’t reproduce; when I check this stuff with my ‘LOM.Navigator’ it clearly shows me on Live 8.2 that I have 9 device parameters. When I add an instrument to the track and check the Looper out again I still have 9 device parameters. Nothing changes.

Hmm, this actually gives me a new idea for a feature; a more easier way to ‘list’ stuff (for example; if you want to quickly check out all the names of those parameters).

Alas: ‘Device On’, ‘State’, ‘Feedback’, ‘Reverse’, ‘Monitor’, ‘Speed’, ‘Quantization’, ‘Song Control’ and ‘Tempo control’. Those are the names of DeviceParameters 1 through 9 (‘path values’ 0 to 8 of course).

That is all which you can control on the Looper. And this fully complies to the stuff available on a control surface like the APC40. I don’t see anything weird here.

Can’t comment on earlier versions that 8.2 anymore though.

EDIT:

If you want to test this stuff for yourself I’d suggest grabbing my LOM.Navigator from here: http://site.synthfan.info/M4LPatches.html

Then simply check out the names on your Live environments; that should tell you exactly what is up.


October 5, 2010 | 8:00 am

thank you for your beautiful patch ..

as you say looper has 9 parameters

but… the second parameter which is the state
(access from "path live_set tracks N devices M parameters 1")

in live 8.1.4 controls play,rec,stop buttons

for some alien reason in live 8.1.5 controls
the clear button! none of the other 8 parameters controls

play,rec,stop button

so the only answer is when you have a looper in the second track

(midi/audio) as first device, with the patcher i gave you control

the clear button or the play,stop,rec buttons from the toggle(and

from the integer)?

the first case means that a bug exists in looper version 8.1.5
the second that an alien has invades in my laptop..


October 5, 2010 | 8:03 am

this is a bug. please check:


Viewing 4 posts - 1 through 4 (of 4 total)