Forums > MaxMSP

pluggo vst parameters

August 27, 2006 | 8:34 pm

I have a problem with pluggo plug-ins in vst~. Parameter values are not
reportet to the 4th outlet of vst~, IF you call a program by a message
into the vst~ inlet, AND the vst~ window is not open.
If the window is open values are reportet.

This patch should show the behavior:

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 284 53 26 196617 plug;
#P message 602 267 30 196617 open;
#P newex 349 247 27 196617 + 1;
#P newex 289 231 32 196617 print;
#P newex 349 185 78 196617 prepend append;
#P user ubumenu 349 219 100 196617 0 1 1 0;
#X add "Phasy Breakup";
#X add "Nasal Chorus";
#X add "Mixexpressed Anxiety";
#X add "Yeah Yeah";
#X add "Rubber Stadium";
#X add "Watery Flange";
#X add "Polite Twister";
#X add "Chorus of Flappers";
#X add "Some Short Echoes";
#X add "Punchy Zzzzz";
#X add "Broken Flanger";
#X add "Decaying Bub Chor";
#X add "Unstable Friends";
#X add "High School Football";
#X add "The Phasing Effect";
#X add "Bam! Pow! Zap! Check?";
#X prefix_set 0 0 0;
#P message 441 183 33 196617 clear;
#P message 45 115 56 196617 pgmnames;
#P newex 45 89 27 196617 b 2;
#N vst~ loaduniqueid 1024132096;
#P newobj 284 153 79 196617 vst~;
#P newex 84 50 162 196617 loadmess plug "Average Injector";
#P newex 44 192 31 196617 dac~;
#P newex 44 164 111 196617 loadmess startwindow;
#P window linecount 4;
#P comment 479 204 158 196617 when changing the preset program here ,
no parameter values are printet unless the vst~ window is open;
#P window linecount 1;
#P comment 455 221 27 196617 < --;
#P connect 2 0 3 0;
#P connect 6 0 7 0;
#P connect 4 0 5 0;
#P connect 4 0 6 0;
#P connect 14 0 5 0;
#P fasten 7 0 5 0 50 141 289 141;
#P fasten 12 0 5 0 354 268 263 268 263 148 289 148;
#P fasten 13 0 5 0 607 302 245 302 245 144 289 144;
#P connect 5 3 11 0;
#P connect 5 5 10 0;
#P connect 10 0 9 0;
#P connect 8 0 9 0;
#P connect 9 0 12 0;
#P fasten 6 1 8 0 67 110 446 110;
#P window clipboard copycount 15;

/J


Viewing 1 post (of 1 total)