Forums > MaxMSP

Plzzz help help… DSP won't start

January 30, 2009 | 7:06 pm

Hey guys,
I had compiled an application of a patch I wrote, everything was working till couple of weeks ago, now when I start it up for some reason I can not get the dsp started.
just can’t turn it on, anyone knows why?

see image attached and please help me if you can, I would really rather not have to go back and recompile the patch !!
thank you
David


January 30, 2009 | 7:26 pm

Hi David,

All those error messages complaining about the absence of adstatus don’t
look at all good, and will make whatever the DSP status window says
entirely fictional, AFAIK.

Have you tried reintsalling the runtime? Does the patch still work
within max?


Owen

David wrote:
> Hey guys, I had compiled an application of a patch I wrote,
> everything was working till couple of weeks ago, now when I start it
> up for some reason I can not get the dsp started. just can’t turn it
> on, anyone knows why?
>
> see image attached and please help me if you can, I would really
> rather not have to go back and recompile the patch !! thank you David
>
>
>
> ————————————————————————
>
>


January 30, 2009 | 7:56 pm

Thanks for the quick response,
yeah I have reinstalled the environment, I also can’t check now if the patch works in max, but I had programmed it in the latest version of max and everything was working fine, so I’m not sure what happened !!

Best
David


January 30, 2009 | 8:09 pm

If you don’t use externals, try to just open the original patch (not the
application) with Max 5 or Max 5 Runtime. Let us know if that works.
J-F.

>
> Thanks for the quick response,
> yeah I have reinstalled the environment, I also can’t check now if the patch
> works in max, but I had programmed it in the latest version of max and
> everything was working fine, so I’m not sure what happened !!
>
> Best
> David


January 30, 2009 | 8:19 pm

I’ll try it when I get home and let you know.

yeah I am using externals


January 30, 2009 | 10:42 pm

> I’ll try it when I get home and let you know.
>
> yeah I am using externals

Then, you may need updated versions of your externals (UI externals for
sure, the others may work even if they were intended for Max 4).
Try maxobjects . com for updates.
J-F.

Jan 28th update: Audio Freeze – From Melody to Harmony

http://www.jeanfrancoischarles.com


January 30, 2009 | 11:08 pm


January 31, 2009 | 12:23 am

thanks for the help, but I don’t think that’s the issue, you see I did include all the externals and indeed they were working perfectly for max 5.
Also, the application itself was working perfectly until about 2 weeks ago !!

I will try including the dsp abstraction.

one thing is that I had originally programmed it and compiled the application while I had my firewire sound card connected, although it did work after that without that sound card, I suspect that there is a problem there.

I will try your suggestions and then let you know of the outcome.

thanks again

David


January 31, 2009 | 8:27 am

i have had this happen a couple of times.
do you use the standalone-object?
do you create a preference file with a name specific to that
application?
that usually helped me sort this kind of trouble.

hth
hans

http://www.hans-w-koch.net

Am 31.01.2009 um 01:23 schrieb David:

>
> thanks for the help, but I don’t think that’s the issue, you see I
> did include all the externals and indeed they were working perfectly
> for max 5.
> Also, the application itself was working perfectly until about 2
> weeks ago !!
>
> I will try including the dsp abstraction.
>
> one thing is that I had originally programmed it and compiled the
> application while I had my firewire sound card connected, although
> it did work after that without that sound card, I suspect that there
> is a problem there.
>
> I will try your suggestions and then let you know of the outcome.
>
> thanks again
>
> David


January 31, 2009 | 4:30 pm

I have experienced what *might* be a related problem, though I am not sure that it would explain why an app you generated would work ok for some time then stop working unless there was a system interaction involved.

In any case, starting the dac automatically (ie via loadbang) on load does not appear to work. I can not get a patch to start audio with a loadbang without additionally stopping audio and starting it (via delays), or, delaying the start message.

Illustration attached. Interested if anyone else can reproduce or explain. This may be system related so for the benefit this is with 5.0.5 (36470) running on a early 2008 MacBook pro with 10.5.5.

– Pasted Max Patch, click to expand. –

January 31, 2009 | 11:54 pm

maybe this could help?
/J

– Pasted Max Patch, click to expand. –

February 1, 2009 | 11:30 am

Thanks Jakob, it *should* help, but no, it doesn’t.

Yes, the DSP status window indicates that DSP is on – something I meant to add in my previous post – but no audio is produced. To illustrate this I added a oscillator and meter to your patch and it should show some signal but there is none. See the pic attached

I didn’t mean to hijack this thread either but troubled by this…


February 2, 2009 | 3:05 am

ok, this keeps getting more weird,

I opened my original patch just a patch and it worked fine, but then when I compiled the application again, it still doesn’t work !! any ideas?


February 2, 2009 | 3:50 am

It works !!!!

ok, so I replaed the dac~ object, then added the adstatus driver object, in fact I added the subpatch p driver-options from the ads help files and recompiled and it all seems to work now !!

thanks for all your help, if you have a reason why this works and can explain it to me, please do so.

also, how to include a preference file for all your settings with a patch that you build into an application?

I can store settings and read them, I can also create an xml file of the settings and load it in, but I’m not sure how to always store the settings to the same file by default, so that it always works, and so that if I give the app to someone else they get all the settings etc…

thanks again
David


Viewing 14 posts - 1 through 14 (of 14 total)