Forums > MaxMSP

Poly Isn't

June 10, 2013 | 2:10 am

Right – I’m driving myself nuts with this. Hopefully it’s obvious to someone what I’m doing wrong here.

This was, recently, playing more than one note at once. Polyphonic heaven. Now I’ve buggered it up and can’t work out why. It’s now completely, frustratingly and unexplainably monophonic.

Any ideas?

(Hopefully I’ve got the formatting right here – first time posting…!)

Thank you!!

<code>

– Pasted Max Patch, click to expand. –

</code>


June 10, 2013 | 3:32 am

you should also post the patch that contains your poly~, the problem might be there…


June 10, 2013 | 8:50 am

Ah, good point.

Here’s the other half:
<code>

– Pasted Max Patch, click to expand. –

</code>


June 11, 2013 | 7:04 am

Just had a brief glimpse, does that solve the problem?

<code>

– Pasted Max Patch, click to expand. –

</code>


June 11, 2013 | 2:01 pm

Afraid not, that sounds pretty much identical. Still Mr Mono Synth. Thank you though!


June 11, 2013 | 3:33 pm

Turn on probing in the debug menu, send a note-on and double click poly~ to view the current voice. (you may need to go into edit mode) Work your way up from the output of the patch and see where you start to get non-zero signal.

If I can make a recommendation: avoid using in 2, in 3, in 4, in 5 unless you are really familiar with the target system and need to send different values for those parameters to specific voices. (I don’t think that applies here) You’ll still need to use in 1, btw, to get the notes coming in.

I’d also suggest providing default values for your objects, especially for *~s that don’t have signals going into both inlets. (because *~ with no argument is the same as *~ 0. which will kill your signal) It’ll save you debugging time because you won’t have to remember to send new values when you edit the patch. In my experience, a lot of problems disappear when you (almost) always provide arguments for your objects.

Some very small things: Your FM ratio calculations aren’t working properly because * needs a floating point argument to do floating point math. You can optionally use bondo instead of t b f to synchronize the calculation–I like bondo because if I add a third number to the calculation, it’s pretty easy to update. Line~ should probably have an argument, too, since it normally goes between 1 and 8.


Viewing 6 posts - 1 through 6 (of 6 total)