Forums > MaxMSP

Poly~ problem

April 4, 2009 | 2:46 pm

Help! I’m having problems with poly~ not working

When I open the poly~ help file I get the following in the Max window:

listfunnel: unknown external object type
listfunnel: unknown external object type
listfunnel: unknown external object type
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
poly~: jpatchline_new: outlet index out of range
newobj: 1-Out~: No such object
poly~: jpatchline_new: outlet index out of range
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 1-Out~: No such object
newobj: 2-Out~: No such object
newobj: 1-Out~: No such object
newobj: 2-Out~: No such object
newobj: 1-Out~: No such object
newobj: 2-Out~: No such object
newobj: 1-Out~: No such object
poly~: jpatchline_new: outlet index out of range
poly~: jpatchline_new: outlet index out of range

The problem appeared whe I was looking at Pete Batchelor’s Clatter patch – no audio from the scrubscreen and similar messages in the Max window.

Everything else I do seems to be working…

(Mac OS X 10.5.6, MaxMSP 5.0.6)

any ideas?

Alistair


April 4, 2009 | 5:18 pm

By chance max over here couldn’t find the lcd object. Relaunching max dit not help, but restarting the computer did.

_
johan


April 4, 2009 | 8:40 pm

no such luck here – still not working…
the out~ object is where it should be and I can create one, but when I look at it’s help file, Max window reads:
newobj: 1-Out~: No such object

– and if I double click on the [out~1] in the help file, the 1-Out~ is pink (bogus object?) with 9 inlets & outlets – er…!

– spotted it – the IRCAM spat folder also has Out~ (same name but obviously different…) – ditched that & all fine except for the message:
listfunnel: unknown external object type

not sure if it’s stopping anything from working though.


April 5, 2009 | 3:39 pm
alistair macdonald wrote on Sat, 04 April 2009 22:40
- spotted it – the IRCAM spat folder also has Out~ (same name but obviously different…)
not sure if it’s stopping anything from working though.

The spat~ library that you’re using is not Max 4 compatible. You probably need to find a newer version.

Quote:
- ditched that & all fine except for the message:
listfunnel: unknown external object type

it’s likely that you have a file called listfunnel somewhere in your search path.


April 5, 2009 | 4:49 pm

Thanks for the help.

I do have listfunnel, but it seems to be part of the standard Max distribution. The MultiThreading sub-patcher (in poly~.maxhelp) uses it.

It appears that I had another version (in a lloop.externals folder) – I transferred all sorts of old stuff over to my Max 5 folder when I upgraded & it looks like I need to spoend some time seeimg just what works & what doesn’t. Sorry for time wasting

Alistair


Viewing 5 posts - 1 through 5 (of 5 total)