Polybuffer & umenu

Mar 1, 2013 at 6:58pm

Polybuffer & umenu

When you populate a umenu automagically, like in the polybuffer help patcher you get a umenu where the menu items are foo.1 foo.2 or whatever it is that your polybuffer is called. That strikes me as way less musically useful that having the name of the actual sound file appear. Is there anyway to route the soundfile name into the umenu along with or instead of the buffername and number. I would much rather see a number and descriptive titles like:

1, anton
2, cello-f2
3, cherokee
4, drumLoop
5, jongly
6, rainstick
7, sho0630
8, vibes-a1

Than:

helppolybuffer-2.1
helppolybuffer-2.2
helppolybuffer-2.3
helppolybuffer-2.4
helppolybuffer-2.5
helppolybuffer-2.6
helppolybuffer-2.7
helppolybuffer-2.8

appear in the umenu? I tried redirecting the items in route but I must be doing something wrong b/c the umenue then just appears empty. Here is the relevant part of the polybuffer help patch:

– Pasted Max Patch, click to expand. –
#66800
Mar 1, 2013 at 9:07pm
– Pasted Max Patch, click to expand. –
#240474
Mar 2, 2013 at 9:58am

That works beautifully.

next to sprintf you have a comment that I don’t quite understand. It says: back to polybuffer~ name. What do you mean by that?

#240475
Mar 2, 2013 at 10:45am

It’s just taking the menu index and generating a string that is the associated polybuffer~ buffer name.

#240476
Mar 2, 2013 at 4:54pm

Thanks. It mostly works now…. one thing i have not ironed out is that it triggers the umenu when loading which means when you turn on the dac for the first time you always get a sound. Other than that i have the umenu & my visual freedback working (still ugly). I need to find a better way to disply the sound file name i hate using the right inlet of the message box since the message box always changes shape depending on the length of the text in it…. ack.’

But more importantly, I somehow managed to foul up the set_position thing you added previously. I went over all the ins and outs and now I can’t see what I mess-up.

– Pasted Max Patch, click to expand. –
#240477
Mar 2, 2013 at 5:37pm

okay.. “ignore click” was still checked in the inspector . … i am a jerk.

#240478
Mar 2, 2013 at 5:46pm

BTW, thanks for the dummy buffer idea. I get weirded out when there is stuff printed to the max window in red even though i know it can be safely ignored. I had already ditched embed @embed 1 by time you answered by i was still getting on error and adding the dummy buffer and using that name in info~ and groove~ on load stopped the verbosity. which stops my anxieties. haha.

#240479

You must be logged in to reply to this topic.