polyphonic synth problems

Apr 5, 2013 at 4:50pm

polyphonic synth problems

Hey, I posted a few days ago regarding some problems with my patch. A user named Lokua commented that I hadn’t followed exactly all the steps in the Cycling 74 video. Indeed, I had forgotten the edge~ object, the f object and to connect the mute outlet from the adsr~ to the thispoly~ object. I connected all of these things and it worked for a bit but when I tried to add the gain scalar it suddenly stopped. I feel like I’m going crazy rying to figure this out, I’ve spent hours now. Hopefully someone can shed some light on what’s wrong. The patch and it’s abstraction “Oscillators” are attached.

Attachments:
  1. Oscillators.maxpat
#67494
Apr 5, 2013 at 6:08pm

hi bewing !! where is that “gain scalar” placed uve mentioned ?

#242852
Apr 5, 2013 at 6:19pm

Just in the main “SynthBeginnings” patch. The gain~ object between the poly~ and the ezdac~. I can’t see why it would have messed it up but it’s not working now… I’m really stumped. I feel like there’s gotta be something else wrong because I’ve tried removing the gain~ object but it’s still monophonic…

#242853
Apr 5, 2013 at 6:31pm

[deleted]

#242854
Apr 5, 2013 at 7:27pm

actually it should work fine !!! i dont know whats going on . it does not triggers any other notes . im stupid right now ,i really dont know

#242855
Apr 5, 2013 at 7:34pm

note that you need to unpack note before swap

#242856
Apr 5, 2013 at 7:40pm

works :)

#242857
Apr 5, 2013 at 7:48pm

A bunch of things fixed. Comments in green.

First the Oscillators patch:

– Pasted Max Patch, click to expand. –

Now the top level patch:

– Pasted Max Patch, click to expand. –
#242858
Apr 5, 2013 at 9:34pm

Hello again and thanks for your time!

KrisW – I’m a little unsure what you’ve changed and I’m still having the same trouble. I am both amazed and jealous that it is working for you (haha)…

Chris Muir – You’ve made a lot of changes that make sense, but I can’t seem to get sound out of your patch… Any ideas?

#242859

You must be logged in to reply to this topic.