Possible bug using poly_mode on macbook pro?

May 24, 2013 at 4:26am

Possible bug using poly_mode on macbook pro?

Hi List!

Weird problem here: with jit.gl 3d shapes, poly_mode set to non-zero values seems to be horribly inefficient on my new macbook pro retina.

See example patch below.

It runs at 14 fps on my new macbook pro retina (15-inch, Early 2013. 2.7 Ghz Intel Core i7. NVIDIA GeForce GT 650M 1024 MB. OS X 10.8.3)
…and it runs at 60(!) fps on my old macbook pro (15-inch, Late 2011. 2.3 Ghz Intel Core i7. AMD Radeon HD 6670M 1024 MB. OS X 10.7.5)

what could possibly be the cause? Graphics card? OS? Max not liking retina? Something else?

thanks to anybody who can shine any light on the issue

<code>

– Pasted Max Patch, click to expand. –

</code>

#250568
May 29, 2013 at 2:40am

Hi List!

Since nobody posted a simple answer/sollution, I would really appreciate it if some of you could:
post your specs and the fps at which this patch runs on your system.

That might help get to the core of whats going on here. Thanks in advance!

-t

#251069
May 29, 2013 at 2:44am

Hi List!

Since nobody posted a simple answer/sollution, I would really appreciate it if some of you could post your specs and the fps at which this patch runs on your system.

That might help get to the core of whats going on here. Thanks in advance!

-t

#251070
May 29, 2013 at 3:11am

Sorry man, no retina here…

#251073
May 29, 2013 at 10:14am

I’m getting 60 fps on a 2012 imac. Sorry I can’t be more help.

#251112
May 29, 2013 at 11:17am

For optimal graphics performance on retina devices at the cost of resolution, I would suggest that you disable retina support on the Max application. Get Info on the application in the finder and check the box for “Open in Low Resolution”.

#251120
May 31, 2013 at 7:06am

Thanks nnneuromodulator and hi Joshua!

Thanks, but unfortunately the low resolution trick doesnt change a bit. I also tested the patch in max 5, which gives the same results.
On my older macbook the framerate actually increases a bit when I set poly_mode to 1 1. On the newer one it dramatically decreases. My fear is that this might be inherent to some suckiness in the way that NVIDEA Geforce handles the drawing of lines (as opposed to the AMD Radeon in my older laptop).

#251293
May 31, 2013 at 2:56pm

hi tarik, i can confirm this slowdown on a windows machine with an nvidia GPU.

so it’s not related to mac OS or retina machines, but nvidia gpus, as you’ve mentioned above.

in this case, i don’t have much to suggest anything other than using gl.mesh @draw_mode lines or lineloop, rather than gl.gridshape.

#251333
May 31, 2013 at 4:50pm

Indeed. On my hackintosh osx 10.8.3, i7, nvidia GTX670 it drops down to 19fps. Things do improve drastically with lower dim settings. With dim 100 100 I get 190fps (qmetro 1 and sync 0).

#251340
May 31, 2013 at 4:53pm

Btw, your older macbook has AMD gfx. I’ve been reading that AMD is better at openGL than nvidia.

#251341
Jun 1, 2013 at 1:47am

So, no solution but some very good (though disappointing) answers. Thanks! Its simply the nvidia card that sucks -completely- at doing this. Using gl.mesh with @drawmode lines/lineloop gives quite different (for meless desirable) results but its definitely the closest approximation while keeping up my framerate. I’ll be using that for now.

Thanks guys!

#251359
Jun 1, 2013 at 1:48am

So, no solution but some very good (though disappointing) answers.

Its simply the nvidia card that sucks -completely- at doing this. Using gl.mesh with @drawmode lines/lineloop gives quite different (for me less desirable) results but its definitely the closest approximation while keeping up my framerate. I’ll be using that for now.

Thanks guys!

#251360
Jun 1, 2013 at 4:31am

I opted for a desktop system because of cases like this, being stuck with whatever components are in a laptop. I prefer being able to switch things around. Portability becomes an issue though…

#251368
Jun 15, 2013 at 8:38am

I’ll confirm: it runs at 14 fps on my macbook pro retina (15-inch, Early 2013. 2.8 Ghz Intel Core i7. NVIDIA GeForce GT 650M 1024 MB. OS X 10.8.4)

Sigh.
-Robert

#252849
Jun 15, 2013 at 8:47am

And 29.9 fps on macbook pro 17-inch, Mid 209,2.8 GHz Intel Core 2 Duo, NVIDIA GeForce 9600M GT 512 MB, OS X 10.8.4.

#252850

You must be logged in to reply to this topic.