Forums > MaxMSP

Presentation mode question

April 30, 2009 | 12:42 pm

how do i get a patcher thats in a patcher to display at the top level

i got a waveform editor that is two patchers deep and want it on the top


April 30, 2009 | 1:02 pm

Look at the [pcontrol] object helpfile for opening [patcher]s.

lh



jln
April 30, 2009 | 2:44 pm

You have to use bpatchers (with the attribute ‘open in presentation’ set) if you want some subpatchers to appear in your main patcher window in presentation mode.

I would LOVE being able to add some objects to presentation mode no matter how deep they are in the patch hierarchie. I hope we could see this in future versions.

Best,
Julien


April 30, 2009 | 11:13 pm
fader12 wrote on Thu, 30 April 2009 07:42
how do i get a patcher thats in a patcher to display at the top level

i got a waveform editor that is two patchers deep and want it on the top

[pcontrol] is one way, as mentioned—you can send it an "open" message, which can be triggered by a key or a MIDI control, for example. Also look at the window commands to [thispatcher], you can have your editor be a floating window so that it’s always on top, until you close it. Just be wary of editing a floating window, most key commands won’t go into it, but mouse actions will. I’d keep it non-floating until you’re done.

window flags float, window exec –> message to [thispatcher]
or
window flags nofloat, window exec

Also you can look at All Windows Active in the Options menu, with this on windows behave differently… they won’t come to the front unless you click the title bar (rather than anywhere in them). Can be useful for managing multiple windows at once and being able to see what you need.


Viewing 4 posts - 1 through 4 (of 4 total)